QTDIR paring Error after latest Visual Studio update



  • Greetings,
    yesterday I updated my Visual Studio to Update 3.
    When I try to open my .pro I get this Error:

    --- (Import): Generating new project of CGViewer.pro file
    --- (qmake) : Using: C:\Qt\Qt5.7.0\5.7\msvc2015_64\bin\qmake
    --- (qmake) : Working Directory: D:\Workspace\SoSe2016\ComputerGrafik\CGViewer\CGViewer 2
    --- (qmake) : Arguments: -tp vc "CGViewer.pro" -o "CGViewer.vcxproj" QMAKE_INCDIR_QT=$(QTDIR)\include QMAKE_LIBDIR=$(QTDIR)\lib QMAKE_MOC=$(QTDIR)\bin\moc.exe QMAKE_QMAKE=$(QTDIR)\bin\qmake.exe

    [1] - WARNING: Could not parse Compiler option '-std=c++0x'; added to AdditionalOptions.
    [2] - WARNING: You can suppress these warnings with CONFIG+=suppress_vcproj_warnings.
    [3] - WARNING: Could not parse Compiler option '-std=c++0x'; added to AdditionalOptions.

    --- (Import): Error(s): 3
    --- (qmake) : Exit Code: 0

    QTDIR konnte nicht aus Projektdatei CGViewer.vcxproj geparst werden.
    --- (Import): Generated project could not be loaded.
    --- (Import): Please look in the output above for errors and warnings.

    Here .pro:

    #-------------------------------------------------
    #
    # Project created by QtCreator 2014-03-06T11:52:40
    #
    #-------------------------------------------------
    
    QT          += core gui opengl
    
    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
    
    TARGET = CGViewer
    TEMPLATE = app
    
    OBJECTS_DIR		= ./obj
    MOC_DIR 		= ./moc
    
    QMAKE_CXXFLAGS += -std=c++0x
    
    SOURCES     +=  src/main.cpp\
                    src/Mainwindow.cpp \
                    src/Scene.cpp \
                    src/EditWidgets.cpp \
                    src/Model.cpp \
                    src/Light.cpp \
                    src/Sphere.cpp \
                    src/Skybox.cpp
    
    HEADERS     +=  src/Mainwindow.h \
                    src/CGTypes.h \
                    src/Scene.h \
                    src/EditWidgets.h \
                    src/Model.h \
                    src/Light.h \
                    src/Sphere.h \
                    src/CGFunctions.h \
                    src/Skybox.h
    
    CONFIG      += mobility debug console
    MOBILITY    =
    
    
    OTHER_FILES += \
                        shader/fragment.glsl \
                        shader/fragment_cel.glsl \
                        shader/vertex.glsl \
                        shader/sphereFragment.glsl \
                        shader/sphereVertex.glsl \
                        shader/rayVertex.glsl \
                        shader/rayVertex.glsl \
    					shader/skybox_vertex.glsl \
    					shader/chosen_fragment.glsl \
    					shader/skybox.glsl \
                        shader/fragment_selected.glsl \
                        plane/plane.obj \
                        plane/plane.mtl \
    
    LIBS += opengl32.lib
    CONFIG += c++11
    
    

    On my laptop on which I have not done that update everything is running as usual.
    I already tryed the Visual Studio repair setup with no success.

    I hope that I do not need to reinstall Visual Studio update 2 to get rid of the new update.


  • Moderators

    @Artorias
    We are talking about VS2015?
    And i suppose you are using the unofficial Qt Addin (Qt5Package)?


  • Qt Champions 2018

    @Artorias Regarding "WARNING: Could not parse Compiler option '-std=c++0x'": if you want to activate C++11 then use

    CONFIG += c++11
    

    instead in PRO file



  • @raven-worx
    Yes I am using this add in



  • @jsulm
    in my last collum i already use CONFIG += c++11


  • Qt Champions 2018

    @Artorias Then there is no need for QMAKE_CXXFLAGS += -std=c++0x



  • @jsulm thanks for the tipp!

    I solved my problem by reinstalling VS2015 Update 2.