WebKit and WebEngine not found in Qt 5.7



  • Hi,

    I have developed one Qt Quick application with Qt 5.2.0. The application contain a webview which must read youtube video but after youtube page loaded, video dont read. And when I stop the compilation, I get an error : LEAK : webcontext

    After many google search, I haven't found solutions to the problem. I decided to export the application verse Qt 5.7. After installing of Qt 5.7, when I try to add webkit or webengine in my file .pro, I get Project ERROR: Unknown module(s) in QT: webengine or Project ERROR: Unknown module(s) in QT: webkit

    I have searched webengine or webkit modules in MingGW/mkspecs/modules and MingGW/bin but I have found nothing.

    Can you help me to install webkit or webengine for my Qt 5.7 ?
    I'm using on Windows 8.1.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    For the QtWebKit module, you'll have to compile it by hand from sources. It's been deprecated in Qt 5.5 and remove from the pre-built package in 5.6. However you can still get it from sources.

    As for the QtWebEngine module, AFAIK, on windows you need VisualStudio 2015. That's not a Qt requirement but Chromium.



  • Thank for your answer.
    I have never used Visual Studio. I prefer to compile QtWebkit from source. But I don't know how to do that ? Can you tell what to do ?

    Else, if I want to use Visual Studio, I have to compile the project inside ?


  • Lifetime Qt Champion

    If you get the sources from the installer, you can open it in Qt Creator and build it the same way as any project.

    No you don't, you can still use Qt Creator. The VS IDE is not needed at all.



  • Thank
    But what will be the consequences on the deployment if I use WebEngine with VS 2015 installed?


  • Lifetime Qt Champion

    You'll deploy your application with the VS2015 version of Qt in place of the MinGW version.



  • Hi @SGaist

    I have installed the mvs2015 from the Qt installer. I have also installed the Visual C++ Compiler 2015. I no longer get the error : Project ERROR: Unknown module(s) in QT: webengine but when I try to include #include <qtwebengineglobal.h> or import QtWebEngine 1.0, I get this error : No such file or directory


  • Lifetime Qt Champion

    Did you do a full rebuild of your project ?

    Also, it should rather be #include <QtWebEngineGlobal>



  • Thank @SGaist, it work now
    But i get some error when I run the project (very minimal code) :

    [0623/090553:ERROR:texture_manager.cc(2278)] [.CommandBufferContext.RenderCompositor-0446EC80]GL ERROR :GL_INVALID_ENUM : glTexImage2D: <- error from previous GL command
    [0623/090553:ERROR:gles2_cmd_decoder.cc(2109)] [.CommandBufferContext.RenderWorker-0446EF60]GL ERROR :GL_INVALID_ENUM : GLES2DecoderImpl::DoBindTexImage2DCHROMIUM: <- error from previous GL command
    

    But the project run


  • Lifetime Qt Champion

    Sorry, that part I can't help you with. Looks like the error comes from Chromium itself.



  • Ok. Thanks for all.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.