Online installer only lists old version in "Select Components"



  • I am on Ubuntu 14.04 32bits (x86).
    Previously I installed Qt 5.6 by building from source (there was no 32bit binary I could find).

    Now I'm trying to install Qt 5.7.0 (Linux 32 bits) to try out.

    I downloaded Qt Online Installer for Linux 32-bit (33 MB) from here

    https://www.qt.io/download-open-source/#section-2

    qt-unified-linux-x86-2.0.3-1-online.run

    But on running the downloaded installer the Select Components window does not show Qt 5.7.0 (only up to Qt 5.5) so I could not progress further with installation.

    • list item

  • Lifetime Qt Champion

    Hi,

    Taking a look at the reference platforms here, only 64 bit linux is mentioned.

    So you'll have to build Qt yourself if you need to target 32bit distributions.



  • @SGaist why Qt Stop Build for 32-Bit Linux?


  • Lifetime Qt Champion

    It's just the pre-built packages that is not offered anymore. Qt itself still builds and support 32bit Linux.

    Reasons can be found here but basically: downloads number for the 32bit version has been going down for some times now.

    Package creation, test and validation is a time consuming task thus this allows to avoid keeping resources busy for something that is not widely used anymore.



  • For those who still require Qt 5.7 installed on Linux 32bits (older generation machines) I have just successfully installed Qt 5.7 into Ubuntu 14.04 (32bits) using this PPA. I retain Qt 5.6 (from same PPA).

    https://launchpad.net/~beineri/+archive/ubuntu/opt-qt57-trusty

    On Ubuntu I used the utility Y PPA Manager to add new PPA (although it can be done through Ubuntu Software Centre).

    Then launching Ubuntu Software Centre > All Software I selected
    Qt 5.7 for /opt Trusty

    Then I installed packages

    I started with
    The full stack of Qt 5.7 release
    qt57-meta-full

    Followed by others such as Qt Creator.

    Note that the links under Ubuntu Applications > Programming are not created until you logout and login again.

    The only quirk I have is that Qt 5.7 Creator does not show in Applications > Programming menu but I can launch it from /opt/qt57/bin/qtcreator.

    I will manually add a launcher link. This might be because I had Qt 5.6 Creator installed and that was removed in the installation process ...

    At the point of installing Qt Creator this message appeared from Ubuntu Software Centre ...

    To install qt57creator, these items must be removed
    
    Lightweight integrated development environment (IDE) for Qt
    qt56creator
    
    Documentation for qt creator ide
    qt56creator-doc
    
    Qt project build system
    qt56qbs
    
    


  • The download page should be changed. The **Qt Online Installer for Linux 32-bit ** doesn't give ANY hint that it does not actually support the 5.6.x and above and one has download the online installer, start it and then see that Qt 5.5 is the last version it supports. Sure, scrolling down to the offline installers does provide this information but my guess would be that there are many people who just go for the online installers.

    PS: I find providing Qt 5.6 and above for 32 bit Windows very discriminating. Building Qt from scratch is of course an option but spending I don't know how much time (especially on an old machine or a virtual one (like in my case) with limited resources is not a very nice way to play.


  • Lifetime Qt Champion

    @Red-Baron Hi, here you can find the reason why the Linux 32bit installer is not provided anymore.



  • Hi, @SGaist. I've already read that (thanks for pointing it out though). The post doesn't mention specific numbers. Also given the time required by a single user to compile the whole SDK compared to compiling it once, uploading it online and allowing people to install it without too much fuss does justify to keep the support for this kind of distribution a little longer. There are plenty of 32bit virtual machines out there with Linux used for creating a easy deployable development environment for Qt applications (at my company we have a lot of embedded development going on on both Linux and Windows and there are a lot of VMs running - 32bit VMs require much less resources (RAM specifically) compared to their 64bit counterparts). Unless some accurate statistic is shown to convince me (nope, "were decreasing all the time" is not good enough) I'll keep saying that it's pretty disappointing (personal opinion of course) for this difference between Windows and Linux support on part of the Qt company.


  • Lifetime Qt Champion

    There's one tiny big detail that you are not taking into account: the numbers of platforms with pre-built packages already provided. The packages are not just generated and thrown on a server.

    Each one is generated with the help of the CI, tested and validated. All these tasks requires people, time and hardware which are sadly limited resources.

    The goal of the project has always been to have a support as wide as possible and make it easy for as many people as possible but they still have to do everything with what they have at hand.



  • @eureka Can you please guide in how to retain qt5.7 and install qt5.6.2 from the PPA.
    My steps are.

    1. Adding ppa using
      sudo add-apt-repository ppa:beineri/opt-qt562-trusty
    2. Than calling update
      sudo apt-get update

    This update is giving me the error,
    W: Failed to fetch http://ppa.launchpad.net/beineri/opt-qt57-trusty/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found.

    As you you can see i am trying to fetch qt5.6.2, but apt-get update is trying to fetch qt5.7.

    Please help in installing qt5.6.2 from the ppa, i already have qt5.7 from the same ppa.


  • Lifetime Qt Champion

    @seemar From a quick look at the PPA, opt-qt57-trusty doesn't exists hence your error.



  • @SGaist In this link https://launchpad.net/~beineri/+archive/ubuntu/opt-qt562-trusty, it is
    saying to execute Source /opt/qt56/bin/qt56-env.sh. I cant able to find the script in that directory. Can you help me in setting up the environment and than installing the qt5.6.2.


  • Lifetime Qt Champion

    You should be able to do that once you installed the package.

    No I can't further, if I need a specific version of Qt I usually build it myself.



  • @SGaist hi, can you please tell how to build qt 5.6 in 32 bit ubuntu 16.04.
    I have tried to build it from source but my version is still showing 5.5.
    Help will be appreciated.


  • Moderators

    @nitish_linked Well, download the Qt 5.6 source code and build it. How do you know that your version is still 5.5? And how did you build it?



  • @jsulm Hi, thanks for replying.
    My machine previously had Qt5.5, so i decided to upgrade it to Qt5.6.
    For that, I followed the following steps :-
    1.) Downloaded qt-everywhere-opensource-src-5.9.2
    2.) ./configure -prefix $PWD/qtbase -opensource -nomake tests
    3.) make -j 4

    It will be great if you can guide me if i am doing some mistake.


  • Lifetime Qt Champion

    Why are you using Qt 5.9.2 sources if you want to build Qt 5.6 ?

    In any case, you should also add -nomake examples.


  • Moderators

    @nitish_linked You forgot to call "make install". And later if you call qmake use absolute path to it to make sure you call qmake from that Qt.



  • @jsulm thanks for help !!



  • @SGaist thank you very much for your help !!


  • Lifetime Qt Champion

    You're welcome !

    Since you have it working now, please mark the thread as solved using the "Topic Tools" button so that other forum users may know a solution has been found :)



  • @jsulm hi, i followed the steps told by you, and this time I also executed the command make install . But, when i perform qmake -v , it is still showing qt version 5.5.
    Is there a problem of absolute path of qt ??


  • Lifetime Qt Champion

    By calling only qmake you are calling your distribution provided qmake, use the full path if you want to call a specific Qt version.


  • Moderators

    @nitish_linked As @SGaist said use absolute path to your qmake. If you just call qmake the system looks in some predefined locations (like /usr/bin) and in directories PATH is showing to and finds qmake from your distribution.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.