Qt Legal/Licensing Questions



  • Hi all,
    I am currently developing a software written in C++ for Mac OSX using OpenCV and Qt OpenSource as the gui framework.
    As I intend to sell the software closed source I wanted to ask what requirement the software has to meet in order to be legally based on the Qt OpenSource framework and be closed source.

    I've read the FAQ here and read the LGPL license, but I'm quite unsure.

    Firstly about the term "unmodified". What needs to remain unmodified? I've subclassed a few classes of Qt in my application like QGraphicsScene, is that modifying Qt itself?

    In terms of building, I an only using dynamic links in my .pro file and I am using the macdeploy tool to create the final App.
    I the app package I see a lot of .dylibs inside the "framworks" folder. Which refers to me as dynamically linked frameworks.

    I've tested the Application on another machine with no Qt or OpenCV installed at all and it worked so the .dylibs inside my App package seem to do the job

    Thanks,
    Marco



  • From your description you are all good



  • @VRonin Thanks for the answer.
    Just to be sure, this is my output when I run otool -L on my .app
    Does that look ok?

    @executable_path/../Frameworks/libopencv_core.3.1.dylib (compatibility version 3.1.0, current version 3.1.0)
    @executable_path/../Frameworks/libopencv_imgcodecs.3.1.dylib (compatibility version 3.1.0, current version 3.1.0)
    @executable_path/../Frameworks/libopencv_highgui.3.1.dylib (compatibility version 3.1.0, current version 3.1.0)
    @executable_path/../Frameworks/libopencv_imgproc.3.1.dylib (compatibility version 3.1.0, current version 3.1.0)
    @executable_path/../Frameworks/libopencv_objdetect.3.1.dylib (compatibility version 3.1.0, current version 3.1.0)
    @rpath/QtWidgets.framework/Versions/5/QtWidgets (compatibility version 5.6.0, current version 5.6.0)
    @rpath/QtGui.framework/Versions/5/QtGui (compatibility version 5.6.0, current version 5.6.0)
    @rpath/QtCore.framework/Versions/5/QtCore (compatibility version 5.6.0, current version 5.6.0)
    /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL (compatibility version 1.0.0, current version 1.0.0)
    /System/Library/Frameworks/AGL.framework/Versions/A/AGL (compatibility version 1.0.0, current version 1.0.0)
    /usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 120.1.0)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1226.10.1)

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.