Building Qt 5.6 on windows from git -- missing modules

  • Hello,

    I've been trying to build QT from the git repo and it does not build the sub modules.

    I've followed the instructions on
    and it's not working for me.

    When trying to build a specific modules with nmake module-qtdeclarative I get
    NMAKE : fatal error U1073: don't know how to make 'module-qtdeclarative'

    I'm doing a shadow build.

    these are my QTVars

    @REM Set up \Microsoft Visual Studio 2015, where <arch> is \c amd64, \c x86, etc.
    @REM CALL "C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\vcvarsall.bat" x86_amd64 10.0.10240.0
    @CALL "C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\vcvarsall.bat" amd64
    SET _ROOT=D:\qt5
    SET PATH=%_ROOT%\qtbase\lib;%_ROOT%\qtbase\bin;%_ROOT%\gnuwin32\bin;%PATH%
    REM Uncomment the below line when using a git checkout of the source repository
    SET PATH=%_ROOT%\qtrepotools\bin;%PATH%
    SET QMAKESPEC=win32-msvc2015

    Is there anything I'm missing?

    By the way it builds OK when I download the source as a zip file.


  • I just did a build using the zip archive for 5.6.1 and most of the modules are missing.

  • My bad.

    I was running config from qtcore and nor the project root!

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.