Unable to debug on OS X



  • Hello world,
    I have updated Qt Creator from 3.something to 4.0.0... Now I simply can't debug anything on OS X 10.11.5, not even a freshly created hello world... Of course I have built on debug mode, and I tried to clean the project and deleted the pro.user file and bla bla bla...
    Qt Creator simply does not start debugging, well it says it starts but nothing happens, the application does not run, but when it manages to run it does not hit the breakpoints. I appreciate if someone knows what is going on and shares with me some ideas.
    Thanks



  • What Version of XCode do you use ?

    Try updating XCode and command Line Tools to the newest Version. Don't forget to start XCode after updating once.



  • Thanks for your answer. Unfortunately it is not the right one. I am running Xcode 7.3.1, and I have now updated the CLT (despite of not needing it according to this)... actually I just installed the operating system (for other reasons), installed Xcode built and ran some projects in Xcode to verify, they work ok. Then installed Qt Creator 4.0.0 it does not debug sometimes it does not even run.



  • Have you solved this problem? I got the same problem:
    https://forum.qt.io/topic/67950/debug-qt-program-failed



  • No, I haven't.
    I want to think that this is a bug. I do not see a reason why a fresh install of everything (OS, Xcode, Qt) would come with a problem like this.



  • I have just updated to 4.0.1... It works Ok again for me


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.