Debug Qt program failed



  • When I debug the qt widget program(empty program also tried) on mac, there are no breakpoints hit. And I got this application output: debugging starts, debugging has finished.
    The environment is : Qt 5.2.1 , Qt Creator 3.0.1, xcode 7.3.1 , clang compiler, lldb debugger.
    I have searched the solution on line for a long time, but the problem hasn't solved, I really need help ,thanks very much!



  • The first time to debug a program, it gets error:
    "An error occured when attempting to write to the LLDB process.
    For example, the process may not be running, or it may have closed its input channel".



  • Does lldb work outside Qt Creator? Does debugging work with gdb? If you load the executable in gdb, do the debug symbols get loaded?

    Are you using macdeployqt? To use debug with macdpeployqt, you need to pass the --use-debug-libs flag. In my case this broke some things in my bundled app as the Qt libs inside the Frameworks folder were now looking for debug versions of the libraries and I had to use install_name_tool on each of them to change the paths. If you end up with this problem I can share the script I wrote for fixing this.



  • The issue seemed to resolved itself when updating qt creator from version 3.0.1 to 3.1.0, the lldb worked well, but the gdb still broken


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.