ECMAScript 6 Proxy support in QJSEngine



  • Hi everyone,

    I know that QJSEngine in Qt5.5 does not yet support ECMAScript 6 Proxy objects. Can anybody tell me if this will change with Qt 5.7, which will use a later version of V8?

    Thanks a lot for your help!

    Edit: Background of the question is that I want to update code heavily relying of QtScript's QScriptClass with QJSEngine, and Proxy objects might help for some of the mechanisms provided by QScriptClass, e.g. dynamic property access.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    That's a question you should rather bring to the interest mailing list. You'll find there Qt's developers/maintainers. This forum is more user oriented.

    On side note, QJSEngine doesn't use V8. It has it's own engine optimized for QML handling name V4.



  • Thanks for the reply, I will take this to the mailing list!



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.