Build Qt 5.7 beta from source for MSVC2010 32bit



  • Hello everyone,

    I am trying to build Qt source for 5.7 beta for my environment (Windows MSVC2010 32 bit).

    I followed the instructions here: http://doc.qt.io/qt-5/windows-building.html

    After installing Pytnon and ActivePerl, I created my path:
    C:\QtSource\5.7b

    I've created this qt5vars.cmd file and modified the path to "vcvarsall.bat", the root directory
    and the QMAKESPEC

    REM Set up \Microsoft Visual Studio 2010, where <arch> is \c amd64, \c x86, etc.
    CALL "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\vcvarsall.bat"
    SET _ROOT=C:\QtSource\5.7b
    SET PATH=%_ROOT%\qtbase\bin;%_ROOT%\gnuwin32\bin;%PATH%
    REM Uncomment the below line when using a git checkout of the source repository
    REM SET PATH=%_ROOT%\qtrepotools\bin;%PATH%
    SET QMAKESPEC=win32-msvc2010
    SET _ROOT=
    

    I then ran a shortcut from the desktop with the command:
    C:\Windows\System32\cmd.exe /E:ON /V:ON /k c:\qtsource\qt5vars.cmd

    and the working directory "C:\QtSource\5.7b".

    When I run this I get prompted to accept the license, accept it, but immediately after there is a failure.

    C:\QtSource\5.7b>configure -debug -nomake examples -opensource
    + cd qtbase
    + C:\QtSource\5.7b\qtbase\configure.bat -top-level -debug -nomake examples -open
    source
    
    This is the Qt for Windows Open Source Edition.
    
    You are licensed to use this software under the terms of
    the GNU Lesser General Public License (LGPL) version 3
    or the GNU General Public License (GPL) version 2.
    
    Type 'L' to view the GNU Lesser General Public License version 3 (LGPLv3).
    Type 'G' to view the GNU General Public License version 2 (GPLv2).
    Type 'y' to accept this license offer.
    Type 'n' to decline this license offer.
    
    Do you accept the terms of the license?
    y
    Creating qmake...
    execute: File or path is not found (make)
    execute: File or path is not found (make)
    Cleaning qmake failed, return code -1
    

    Help please?


  • Lifetime Qt Champion

    Hi,

    Re-run configure using the -v switch to get more information about what is happening



  • Tried it now but I'm getting no extra information.



  • execute: File or path is not found (make)
    

    Is there a reason this is using make and not for nmake?


  • Lifetime Qt Champion

    Just saw something, why do you have gnuwin32 in your PATH ?



  • I answer in this thread, because this link is on top 5 of search engine(as for my query).

    So, I've tried all above to Qt 5.7.1 and Qt 5.7.0 both x86 and x64 on Windows 7 with the same result.
    Seems like building with msvc2010 is no longer supported, maybe even in versions below 5.7.0 - didn't checked.

    If you really need Qt for msvc2010 you'd better stick with Qt 5.4.2 or even Qt 4.7.4.

    On Qt 5.4.2 I've faced with some opengl troubles, so entire Qt failed to build - maybe that could be fixed.

    As for Qt 4.7.4 - build process worked like a charm.

    Hope it helps.


  • Lifetime Qt Champion

    Qt 5.7 dropped support for Visual Studio 2010.

    If you still need to use VS 2010 then go with Qt 5.6 which is also an LTS release.

    If you are locked to Qt 4, then please at least use the latest and last version which is 4.8.7.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.