I need to disable auto-save in QtCreator: it is corrupting my disk.



  • I am running VirtualBox Ubuntu 14.04. I use QtCreator as an editor only. When I am running no other applications, QtCreator will hang during an auto-save for short files. (It is trying to save to a USB 2TB drive. When this happens, the drive is corrupted and VirtualBox will crash just after that. I would like to disable autosave. (I'm capable of saving my own work as needed.) I can find no way to do that. Please note that this is happening about twice a day and disk recovery on a 2 TB drive takes hours. I never see disk corruption except after a prolonged autosave. I never see it when I use other editors.



  • @Flamingo2 Hi, and welcome to the Qt forum! To disable auto-save in Qt Creator, go to Tools > Options > Environment and deselect "Auto-save modified files".


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.