@Flamingo2 Hi, and welcome to the Qt forum! To disable auto-save in Qt Creator, go to Tools > Options > Environment and deselect "Auto-save modified files".