Make error



  • Hi,

    I just installed Qt on my new laptop and tried to write a simple hello world program and ran into the following issue:

    12:30:33: Configuration is faulty. Check the Issues view for details.
    Error while building/deploying project Hello (kit: Desktop Qt 5.6.0 MSVC2015 64bit)
    When executing step "Make"

    Issues view: Needs a compiler to build

    I do have visual studio enterprise 2015 on the machine. I'm running windows 7 64 bit, I do have a kit defined (which was an issue on the desktop). Would the visual studio free version be preferable for some reason? I'm writing in C++. Enterprise was installed before Qt, but it was not used (after this error I started visual studio and went through the whole preparing for first use screen and then tried rebuilding the program and came up with the same errors. This last paragraph is just a brain dump of everything I can think of, and of course I probably missed something important to tell you.

    Thanks you
    Steven


  • Lifetime Qt Champion

    Hi,

    In the Compiler part of the Build And Run, do you have Visual Studio 2015 listed ?



  • @SGaist I will have to check. When I originally checked on this I don't think I saw anything listed. I'll check in a couple house and get back to you. Foolish meetings at work all morning. If I don't see it should I make a screenshot of what I do see for you?



  • You were right, no compiler defined. Additionally my visual studio disk loaded up something called blend for VS. Now sure if this will be a problem. On the desktop the disk loaded up regular VS. Loaded up a path for the compiler, will have to find one for the make function. I will check my paths on the desktop to see what is defined there when I get home tonight. Lets hold this open for today and I'll close it as solved tomorrow if I can get it working based on that I have on the desktop.

    If I cant, get it working with this "blend" think, do you have a recommended alternative to VS like Clang, etc.?


  • Lifetime Qt Champion

    AFAIK, Blend is a GUI design tool so it's not what you want.

    If you are not tied to Visual Studio, you can download the MinGW version of Qt. You can install MinGW using the same installer. No need to grab any external version.



  • I downloaded the minGW version and now it all works perfectly. thank you


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.