[ISSUE] QtCreator 3.6.0, 3.6.1 and 4.0.0 do not start up on windows



  • Hi Everyone,

    I currently have a working 3.0.1 QtCreator on my Windows 7 machine (which I got along with Qt 5.2.1). I installed 3.6.0 but when I start the qtcreator.exe, I see the process starting, nothing shows up and after some time it stops without giving any error message.

    The same has been happening with 3.6.1 and 4.0.0. I even checked if some dlls were not missing in the background using process monitor but none of the 'NAME NOT FOUND' dlls happened twice which means the loading failed in some folder but likely suceeded in another one (otherwise there would be several entries of failed loads on more than one folder).

    Any idea how to solve this ?

    thanks in advance


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Pretty strangeā€¦ How did you install the newer versions of Qt Creator ?

    Does it also happen if you start if from the command line with the -noload Welcome option ?



  • Hi there,

    I have a functionnal 3.0.1 which I got along with Qt 5.2.1. After that, I first got Creator 4.0.0 as standalone. As for Creator 3.6.1, I got it along with Qt 5.6.0.

    I tried your option on both versions:

    • 3.6.1 started properly once, but with or without the option, I cannot get it to start again....
    • 4.0.0 still doesn't start : the behaviour remained the same... any extra option/ verbose mode I can use to have more details on what's going on ?

    Thanks for your support



  • I have one update:
    When I deactivated all plugins except core (-noload all -load Core), both 3.6.1 and 4.0.0 do start up.

    I will continue to check plugins one by one to find the crashing one...



  • Hi Again,

    So I have made detailed test by gradually reactivating plugins when starting 4.0.0 with only core plugin loaded.

    Here are my conclusions about this very silent crash / doesn't start up:

    • when activating QmlDesigner plugin --> Creator doesn't start
    • when activating Welcome plugin --> Creator doesn't start

    Exacly the same problems occurs with 3.6.1: QmlDesign and Welcome Plugins both causes the crash.



  • Hi, I also had problems with the QmlDesigner plugin, I got it working by updating my video driver.
    (more specifically, it's the OpenGL driver).



  • Hi Guys,

    Thanks, indeed this is due to the graphic card... I have 2 of them on his laptop and when I force the ati one, it solves the problem. However if I leave the built in Intel HD chip active as it is by default, it crashes.

    Will look for some drive update for it, thanks !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.