How can I disable the shadow builds perpetually?



  • As work on the Qt projects goes along, at some point the Qt Designer stops updating the ui_<blah-blah>.h files with the new UI elements being added.

    This is due to the shadow builds turned on by default in Qt Creator.

    But I cannot find an option to turn this horrible feature off in this elegant and highly intuitive UI of Qt Creator 3.6.1


  • Qt Champions 2016

    @nulluse
    Go to the left (side bar) click on "Projects". The topmost tab control contains each of your projects, click on the relevant one. Under the tab bar are listed the kits used with two buttons: "Build" and "Run". Select "Build" (if not already selected). In the build settings pane (the larger portion of the screen) there's a checkbox next to "Shadow build" (there's separate option depending on the debug/release configuration).

    Qt creator

    But I cannot find an option to turn this horrible feature off

    PS.
    Btw, shadow building is a great feature. I hate having binaries under my source tree and use it extensively.



  • As long as they work, all great features are awesome. But once they become infuriating show stoppers, they are just that. I wholeheartedly agree that for some having a shadow build is great, but if they cause the issue I am facing, they have to go.


  • Qt Champions 2016

    @nulluse said:

    I wholeheartedly agree that for some having a shadow build is great, but if they cause the issue I am facing, they have to go.

    I doubt shadow building is the culprit, but you could try disabling them for your own peace of heart. One thing that might be interfering is having qmake overwrite the makefiles for multiple projects if they reside in the same shadow build directory. This could happen if you haven't specified a name for the makefile in your project (.pro) file. You may want to try that as well:

    MAKEFILE = myprojectmakefilename
    

    Kind regards.



  • Yes, disabling shadow builds fixes the issue with forgetfulness (or dementia) of Qt Designer. This is a confirmed fact.


  • Moderators

    @nulluse said:

    As work on the Qt projects goes along, at some point the Qt Designer stops updating the ui_<blah-blah>.h files with the new UI elements being added.

    This is due to the shadow builds turned on by default in Qt Creator.

    ...

    Yes, disabling shadow builds fixes the issue with forgetfulness (or dementia) of Qt Designer. This is a confirmed fact.

    Interesting. Can you provide a copy of this fact confirmation, so that the issue can be fixed?



  • I do not know at which point and what triggers the failure to update the header, or exactly how long ago that started on each of the projects, also I am not able to share the entire projects with you, so you might just want to have a look at your code to see where it might fail.

    All I can tell if that as UI grows, and somewhere around a dozen controls on any form the header stops being updated until we turn off the shadow builds. Then it's back to normal. You can question this or interrogate me further, but this is the way it is.



  • If you want to turn off shadow building for all projects you create, just change the settings
    Goto Tools -> Options -> Build & Run -> General Tab -> Default Build directory - set it as "." (dot without quotes))


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.