missing kits



  • Hi,

    I'm a new user (downloaded Qt5.6 last night, so I'm a very new user, running on win 7 core 2 machine). When I start a widget everything works perfectly.

    When i start any other type of application (console App, quick App, etc.) I get an error message saying no valid kits found and giving me the message "Please add a kit in the options or via the maintenance tool of the SDK."

    I have looked and cant figure out where to find these kits, what kits I need or now to get past this issue.

    Can someone explain to me, in a very simple way, how to find and apply the necessary kits to at least get some of these other applications up and running? I am not a programmer so I may need more coaching in the beginning than someone familiar with code writing and computers in general.

    Thank you for assistance and your patience with a new user.
    Steven


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What package did you install ?
    What compiler are you using ?



  • Qt 5.6.0 for Windows 32-bit (VS 2015, 840 MB)

    from this page http://www.qt.io/download-open-source/

    This is the only thing I installed. Is there more I should have installed?


  • Lifetime Qt Champion

    So you don't have Visual Studio 2015 ? You need to install it from Microsoft's developer website.



  • @SGaist I do have visual studio 2015 installed. I thought that Qt was independent of visual studio. That's why I didn't mention it. I know there is a version of Qt that runs inside VS2015, but I thought the one I downloaded ran independent;y.


  • Moderators

    Hi @Steven_DAntonio, and welcome to the Qt Dev Net!

    @Steven_DAntonio said:

    I have looked and cant figure out where to find these kits, what kits I need or now to get past this issue.

    There are many versions of Qt available, and there are many versions of compilers available.

    In a nutshell, a "kit" is a combination of one compiler + one version of Qt that are compatible. Note that a "kit" is a concept specific to Qt Creator.

    When I start a widget everything works perfectly.

    When i start any other type of application (console App, quick App, etc.) I get an error message saying no valid kits found and giving me the message "Please add a kit in the options or via the maintenance tool of the SDK."

    I find this rather odd... if you can create a Qt Widgets Application, you should also be able to create a Console Application.

    To confirm: Are you able to build and run a program that contains a widget?

    Also, can you post screenshots of the following parts of Qt Creator?

    • Tools -> Options -> Build & Run -> Kits
    • Tools -> Options -> Build & Run -> Qt Versions
    • Tools -> Options -> Build & Run -> Compilers


  • I have the screenshots you requested, plus a screen shot showing wigets as it comes up ready to code and a screen shot for console apps showing the error I get. I just can't fine any way to post them to this thread.


  • Moderators

    @Steven_DAntonio said:

    I just can't fine any way to post them to this thread.

    Upload them to an image hosting server (for example, Imgur, DropBox, OneDrive, Google Photos, etc.), make it public, and post the links here



  • OK that is simple, I'll just use my old photobucket site

    http://s1065.photobucket.com/user/sdantonio93/library/Qt?sort=3&start=0&page=1

    after uploading them I logged out and then retested it wo make sure they were all public and they seem to be. This site also has some of my recent work on other things, please feel free to poke around the site if you are interested and feel like killing a few minuets.


  • Moderators

    Your kit selection page has a funny message:

    Qt Creator can use the following kits for project untitled1','pro')":SyntaxError: Expected token ')':

    It looks like something broke there. I've never seen this message before.

    Can you try the following?

    • Create the project in a different folder, with no spaces in the path
    • Give the project a different name


  • I uploaded 3 more gif files to the directory above, They are titled "New Console Project 1-3" so you can see what i did each step of the way. The end results were the same. Have others reported issues with this particular build or am I just lucky to get the only broken install :)


  • Lifetime Qt Champion

    Can you move your project in a folder that doesn't contain spaces or special char and try again ?



  • @SGaist Now that I looked back along the complete path I realized there was a sub folder alone the way that had a blank space and special character. I went a created a folder c:\kits (no spaces no special characters, right on the root of the C drive) and tried launching a console app and it worked fine. So I guess in the future all my Qt stuff will have to be in a folder right on the root of the c drive. Interesting that it worked with widgets but not with any other type of application with that folder along the path.

    Thank you all for your help.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.