Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Uninstall QT



  • I am having some weird issues with QT after updating my GCC I would really like to uninstall it and start some stuff over but I can not seem to remove it. I am on Ubuntu 14.04, I can't run "sudo apt-get remove <package name>" because I can't figure out what the package is. I tried to just delete the qt folder but that did not work as it picked up the old settings when I reinstalled it. It does not show up as an installed app in the Ubuntu software center. How can I uninstall this?


  • Lifetime Qt Champion

    How did you install Qt?
    Did you use the online installer?
    If you say "I tried to just delete the qt folder" then it sounds like you used the online/offline Qt installer. In this case it does not have anything to do with Ubuntu package management.
    If you used the online installer then use the maintenance tool to uninstall it. Deleting qt folder as fine as well.
    Qt settings (at least QtCreator settings) are NOT stored in qt directory. They are in ~/.config/QtProject and ~/.config/QtProject.conf

    Which issues do you have after updating gcc?



  • After I updated GCC to 4.9 to use use std::regex stuff QT wont find my compiler. If I manually point it there it gets an error on the Make command when running the program. I would give more details but that is all the out put says. I had actually found the maintenance tool but it was still loading my old settings when reinstalled. I will try deleting the folder and clearing out the ~/.config/QtProject and ~/.config/QtProject.conf paths see if that helps/



  • As @jsulm already mentioned it would help a lot to know wheter you used the online/offline installed that you downloaded from the Qt website or whether you installed it using Ubuntus package manager.

    In either way this issue can be fixed by just properly configuring the kits. Open the QtCreator -> Tools -> Options... -> Build & Run. In there you can configure the compiler settings and so on.
    If you are not using QtCreator but qmake directly then use the -spec parameter to pass the specification file which contains information about the compiler that should be used.



  • I already figured out how to install it by using the maintenance tool but it was not removing the preferences.
    The problem is QT will not recognize the compiler path. I go to tools->options->compiler->add->put the in the path /usr/bin/gcc for the compiler and it just does not recognize it. I know its there, works fine in Code::Blocks. When I go to the kit it still has the big red warning and will not let me add the compiler to the kit.

    Edit: I removed the config files and uninstalled but it still will not find my GCC 4.9. Even when installing it will not auto detect the compiler nor will it when I select the path manually. Does QT 5.6 have any known issues with GCC 4.9?


  • Lifetime Qt Champion

    "The problem is QT will not recognize the compiler path" - what do you mean by that? What exactly happens?
    You should select g++ not gcc: /usr/bin/g++
    g++ is the C++ compiler of the GNU Compiler Collection (GCC).
    There should be no issues with Qt 5.6 and GCC 4.9.


Log in to reply