Latest version of Qt cant compile anything in .c with MinGW (Win 10 x64)

  • Hello,

    I have a problem with my fresh installation of Qt 5.6.0 with the latest MinGW listed in the Qt installer. It does not compile my files, if I am set to the debugging mode of a project (the computer icon above the run icon, in the bottom left corner of the Qt Creator). But if I switch it to the deployment mode, it suddenly does work. But debugger doesnt do anything in that case.

    When I try to compile & run a new, just written project in debugging/developing mod (I am not sure, since it is still written in my language - I am not using it in English) it gives me the folloving:

    error: INTERNAL: readdir: No such file or directory.  Stop.

    When I open the error, I see this:

    20:37:48: Configuration unchanged, skipping qmake step.
    20:37:48: Starting: "C:\Qt\Tools\mingw492_32\bin\mingw32-make.exe" 
    mingw32-make: *** INTERNAL: readdir: No such file or directory.  Stop.
    20:37:48: The process "C:\Qt\Tools\mingw492_32\bin\mingw32-make.exe" exited with code 2.
    Error while building/deploying project Matice_pointer_na_pointer (kit: Desktop Qt 5.6.0 MinGW 32bit)
    When executing step "Make"
    20:37:48: Elapsed time: 00:00.

    I did some digging on this forum, but sadly, I didnt find any solution yet. No help came with google, either.
    I checked my PATH: there is no MinGW or something like that in there (in case you would be wondering)

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Can you share your .pro file ?

  • TEMPLATE = app
    CONFIG += console
    CONFIG -= app_bundle
    CONFIG -= qt
    SOURCES += main.c

    Here it is.

  • @SGaist Any ideas?

  • Lifetime Qt Champion

    Just tested it with a hello world main.c both in debug and release mode and not problem at all.

    Do you have your project in path with spaces ?

  • @SGaist Apparently, having the project in a folder with "&" symbol in its filepath was an issue. I moved all my projects into a folder without spaces and special characters, and it works. Thank you, I don't think I'd figure it out without your help. :)

  • Lifetime Qt Champion

    Paths can be tricky on Windows

    You're welcome !

    Since you have it working now, please mark the thread as solved using the "Topic Tool" button so that other forum users may know a solution has been found :)

  • @SGaist I am getting the same error. This is my project path:


    As you can see, I dont have any spaces or special characters in my path, except for the colon of C drive, which cannot removed by my knowledge. Can you please help me out?

    Thanks in advance. Really appreciate the help.
    P.S. I am a newbie here. So, please try to help me in layman terms.

  • Lifetime Qt Champion

    Hi @asthana-ujjwal and welcome to devnet,

    Can you show your .pro file ?