Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

debugging via USB on tablet



  • Hey.
    1 year before I wrote an app on tablet sony Xperia Z2, and everything worked corretly. Now after this year I'd like refresh my app.
    When I want debugging my app via USB, I see black sreen on tablet and my app doesn't start. In Qt Creator I see only :
    started debugging
    completed debugging
    and that is all.
    I remember, it worked year before. By the way, app works corretly when I start it from tablet.

    Do you have any suggestions that might not work correctly?



  • The first thing that comes to mind are the settings in the device that enable debugging. Those might have become reset to defaults due to bugs in Android updates. And as the device has probably had the Android updates, you could also check/update the Android SDK version it uses correspondingly to minimize the opportunity for problem-causing differences.



  • @mvuori I updated SDK and Qt. I passed the authorization on tablet to allow to debugging but nothing have changed. Do you have any other ideas?


Log in to reply