Error: "The stream is in the wrong format."



  • Hi.
    I had a program written in Qt 5.4.1 and it worked fine in that version On Ubuntu 64-bit.
    Then I installed Qt 5.6.0 on Arch linux 64-bit.
    but when I run the program, it shows very long line of this error:

    Error: "The stream is in the wrong format."
    

    and then

    No protocol specified
    xcb_connection_has_error() returned true
    shm_open() failed: Too many open files
    

    and lots of this error

    shm_open() failed: Too many open files
    

    and sometimes this error too:

    Error: "The autoaudiosink element is missing."
    

    I tested the program in android and no error occures
    What is the problem? Does it need a package which is not installed on my Arch linux?


  • Lifetime Qt Champion

    Hi,

    You should check your GStreamer installation.



  • Thanks :-)
    Installing gstreamer-ffmpeg solved the problem


  • Lifetime Qt Champion

    You're welcome !

    Since you have it working now, please mark the thread as solved using the "Topic Tool" button so that other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.