I have some error. Hope someone can help me, thanks.



  • 17:08:14: 為專案 pixymon 執行步驟...
    17:08:14: 設置沒有改變,將跳過 qmake 步驟。
    17:08:14: 正在啟動:"C:\Qt\Tools\QtCreator\bin\jom.exe"
    C:\Qt\Tools\QtCreator\bin\jom.exe -f Makefile.Debug
    cl -c -nologo -Zc:wchar_t -FS -Wno-unused-parameter -mno-ms-bitfields -mno-ms-bitfields -Zi -MDd -O0 -GR -W3 -w34100 -w34189 -w44996 -EHsc /Fddebug\PixyMon.pdb -DUNICODE -DWIN32 -DWIN64 -D__WINDOWS__ -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -I..\pixymon -I. -I....\common\inc -I..\windows -IC:\Qt\5.6\msvc2013_64\include -IC:\Qt\5.6\msvc2013_64\include\QtWidgets -IC:\Qt\5.6\msvc2013_64\include\QtGui -IC:\Qt\5.6\msvc2013_64\include\QtANGLE -IC:\Qt\5.6\msvc2013_64\include\QtXml -IC:\Qt\5.6\msvc2013_64\include\QtCore -Idebug -I. -IC:\Qt\5.6\msvc2013_64\mkspecs\win32-msvc2013 -Fodebug\main.obj ..\pixymon\main.cpp
    cl : 命令列 error D8021 : 無效的數字引數 '/Wno-unused-parameter'
    cl -c -nologo -Zc:wchar_t -FS -Wno-unused-parameter -mno-ms-bitfields -mno-ms-bitfields -Zi -MDd -O0 -GR -W3 -w34100 -w34189 -w44996 -EHsc /Fddebug\PixyMon.pdb -DUNICODE -DWIN32 -DWIN64 -D__WINDOWS__ -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -I..\pixymon -I. -I....\common\inc -I..\windows -IC:\Qt\5.6\msvc2013_64\include -IC:\Qt\5.6\msvc2013_64\include\QtWidgets -IC:\Qt\5.6\msvc2013_64\include\QtGui -IC:\Qt\5.6\msvc2013_64\include\QtANGLE -IC:\Qt\5.6\msvc2013_64\include\QtXml -IC:\Qt\5.6\msvc2013_64\include\QtCore -Idebug -I. -IC:\Qt\5.6\msvc2013_64\mkspecs\win32-msvc2013 -Fodebug\videowidget.obj ..\pixymon\videowidget.cpp
    cl -c -nologo -Zc:wchar_t -FS -Wno-unused-parameter -mno-ms-bitfields -mno-ms-bitfields -Zi -MDd -O0 -GR -W3 -w34100 -w34189 -w44996 -EHsc /Fddebug\PixyMon.pdb -DUNICODE -DWIN32 -DWIN64 -D__WINDOWS__ -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -I..\pixymon -I. -I....\common\inc -I..\windows -IC:\Qt\5.6\msvc2013_64\include -IC:\Qt\5.6\msvc2013_64\include\QtWidgets -IC:\Qt\5.6\msvc2013_64\include\QtGui -IC:\Qt\5.6\msvc2013_64\include\QtANGLE -IC:\Qt\5.6\msvc2013_64\include\QtXml -IC:\Qt\5.6\msvc2013_64\include\QtCore -Idebug -I. -IC:\Qt\5.6\msvc2013_64\mkspecs\win32-msvc2013 -Fodebug\usblink.obj ..\pixymon\usblink.cpp
    cl -c -nologo -Zc:wchar_t -FS -Wno-unused-parameter -mno-ms-bitfields -mno-ms-bitfields -Zi -MDd -O0 -GR -W3 -w34100 -w34189 -w44996 -EHsc /Fddebug\PixyMon.pdb -DUNICODE -DWIN32 -DWIN64 -D__WINDOWS__ -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -I..\pixymon -I. -I....\common\inc -I..\windows -IC:\Qt\5.6\msvc2013_64\include -IC:\Qt\5.6\msvc2013_64\include\QtWidgets -IC:\Qt\5.6\msvc2013_64\include\QtGui -IC:\Qt\5.6\msvc2013_64\include\QtANGLE -IC:\Qt\5.6\msvc2013_64\include\QtXml -IC:\Qt\5.6\msvc2013_64\include\QtCore -Idebug -I. -IC:\Qt\5.6\msvc2013_64\mkspecs\win32-msvc2013 -Fodebug\console.obj ..\pixymon\console.cpp
    cl : 命令列 error D8021 : 無效的數字引數 '/Wno-unused-parameter'
    jom: C:\Users\User\Downloads\pixy-master\pixy-master\src\host\build-pixymon-Desktop_Qt_5_6_0_MSVC2013_64bit-Debug\Makefile.Debug [debug\main.obj] Error 2
    cl : 命令列 error D8021 : 無效的數字引數 '/Wno-unused-parameter'
    jom: C:\Users\User\Downloads\pixy-master\pixy-master\src\host\build-pixymon-Desktop_Qt_5_6_0_MSVC2013_64bit-Debug\Makefile.Debug [debug\usblink.obj] Error 2
    cl : 命令列 error D8021 : 無效的數字引數 '/Wno-unused-parameter'
    jom: C:\Users\User\Downloads\pixy-master\pixy-master\src\host\build-pixymon-Desktop_Qt_5_6_0_MSVC2013_64bit-Debug\Makefile.Debug [debug\console.obj] Error 2
    jom: C:\Users\User\Downloads\pixy-master\pixy-master\src\host\build-pixymon-Desktop_Qt_5_6_0_MSVC2013_64bit-Debug\Makefile.Debug [debug\videowidget.obj] Error 2
    jom: C:\Users\User\Downloads\pixy-master\pixy-master\src\host\build-pixymon-Desktop_Qt_5_6_0_MSVC2013_64bit-Debug\Makefile [debug] Error 2
    17:08:14: 行程 "C:\Qt\Tools\QtCreator\bin\jom.exe" 已離開。離開代碼 2 。
    Error while building/deploying project pixymon (kit: Desktop Qt 5.6.0 MSVC2013 64bit)
    When executing step "Make"
    17:08:14: Elapsed time: 00:00.

    how to solve this problem?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Got any unused parameter in your classes ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.