Qt Creator hangs at startup



  • I'm trying to install gpl (community version) on a Windows 10 Pro computer (64 bit). The computer is a new build. I downloaded qt-unified-windows-x86-2.0.3-online.exe (Open source version) and installed it. The installation completed without error. However, when I try to start Qt Creator (Community) an initial window appears that is just a blank (white) window and it just hangs with a "Not Responding" message at the top. No matter how long I wait, it never starts.

    I've done a complete uninstall using Revo Uninstaller and reinstalled but get the same thing.
    I've tried starting with "Run as Administrator" -> Same thing
    I've disabled my Norton Internet Security and it still hangs.
    I've gone into the Windows system configuration and disabled all non Microsoft services from starting -> still hangs.

    I've successfully installed and run an earlier version on another Windows 10 Pro computer. I just can't seem to get it going on this machine.

    I'm at a loss as to what could be causing this not to start. Any ideas on how to get it going.



  • Hi, check this thread (maybe you have the same problem)



  • Beautiful!!! That solved the problem. Apparently the Welcome screen hangs.



  • @Norm I'm having the same problem, just run qt creator as admin.this gonna work!
    0_1554342728542_ab293c9b-2c49-4c2e-be79-9237d1d4b3ba-image.png


  • Lifetime Qt Champion

    @HaoTian Usually when you have to resort to that kind of workaround, there's something else to be fixed.

    Running development tools and software as root/admin is usually a pretty bad idea. You can destroy your system pretty easily if you execute your application and it contains for example some innocent code that deletes folders and you start that at the root of your disk.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.