SSL Support



  • I am attempting to use QNetworkAccessManager to access a page using https.
    Doing so does not succeed. I get the following output:
    qt.network.ssl: QSslSocket: cannot resolve SSLv2_client_method
    qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
    qt.network.ssl: QSslSocket: cannot resolve SSLv2_server_method
    qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method

    I have openssl installed on my arch linux machine.
    I am running Qt 5.5.1 in QtCreator 3.6.0.
    Everything is 64bit.

    I have done a ton of googling and have found nothing to help me resolve this issue.
    Any suggestions or solutions?

    Thanks.



  • Are you linking openssl libs in your project? What version of openssl are you using


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you print the error you get while using QNetworkAccessManager ?

    The warning you are seeing comes from a mismatch between the OpenSSL version present when building Qt and the one you have. It should be harmless.



  • I actually got it working.
    The SSL warnings threw me off the issue.
    The actual reason my request got no response was because my request URL was incorrectly formatted. (? got encoded as %3F)
    I corrected my request URL and everything works fine. I still get those SSL warnings, but the request runs without error over SSL.


  • Lifetime Qt Champion

    Glad you found out and thanks for sharing !

    Since you have it working now, please mark the thread as solved using the "Topic Tool" button so that other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.