Qt Systems / Qt Service Framework Install



  • Ive been trying for the last few days to work out how to add these modueles to my QT5.5 /5.4 instilation, first of all is this still posible and if so how do i do it every time i run qmake / make i get a make error 2 on the publishsubscribe build process


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What error are you getting ? Where did you get the sources ?



  • Sorry about the late reply just got back from a trip
    i got the source from this repo
    its required for a dead project im working on
    http://code.qt.io/cgit/qt/qtsystems.git/tree/

    its required for a dead project im working on

    this is the full build output
    E:\Qt\5.4\Src\qtsystems>make
    cd src\ && ( if not exist Makefile E:\Qt\5.4\msvc2013_64\bin\qmake.exe E:\Qt\5.4
    \Src\qtsystems\src\src.pro -o Makefile ) && make -f Makefile
    make[1]: Entering directory E:/Qt/5.4/Src/qtsystems/src' cd publishsubscribe\ && ( if not exist Makefile E:\Qt\5.4\msvc2013_64\bin\qmake. exe E:\Qt\5.4\Src\qtsystems\src\publishsubscribe\publishsubscribe.pro -o Makefil e ) && make -f Makefile make[2]: Entering directoryE:/Qt/5.4/Src/qtsystems/src/publishsubscribe'
    make -f Makefile.Release
    make[3]: Entering directory E:/Qt/5.4/Src/qtsystems/src/publishsubscribe' Makefile.Release:106: *** missing separator. Stop. make[3]: Leaving directoryE:/Qt/5.4/Src/qtsystems/src/publishsubscribe'
    make[2]: *** [release] Error 2
    make[2]: Leaving directory E:/Qt/5.4/Src/qtsystems/src/publishsubscribe' make[1]: *** [sub-publishsubscribe-make_first-ordered] Error 2 make[1]: Leaving directoryE:/Qt/5.4/Src/qtsystems/src'
    make: *** [sub-src-make_first-ordered] Error 2


  • Lifetime Qt Champion

    How did you call qmake in the first place ?

    In any case, one simple way to build it is to open the module in Qt Creator



  • i run qmake from the build console provided by qt

    as for compiling with creator dispite not correctly finding the include paths for all the headers i am apparently still missing glib.h and this 'QtCore/private/qcoreapplication_p.h'


  • Lifetime Qt Champion

    Did you call configure in Qt's sources once ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.