Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt creator after running on ubuntu show dark display!



  • when I run the Qt on my PC ( Ubuntu OS) show dark display and do not run.


  • Lifetime Qt Champion

    Try to start it on command line with:
    ./qtcreator.sh -noload Welcome
    If it works then disable the Welcome plug-in under "Help/About Plugins..".



  • thanks. it works but the design is different.
    root@ubuntu:/home/hgh1/Qt5.4.1/Tools/QtCreator/bin# ./qtcreator.sh -noload Welcome
    Cannot start '/usr/lib/i386-linux-gnu/qt4/bin/qmake': No such file or directory
    Warning: No kit '{37568147-209f-45aa-8a73-4f89ed9c468d}' found. Continuing.


    I have another compiler for arm. when I opened Qt with your way, that compiler not load.


  • Lifetime Qt Champion

    Hi,

    Why are you running Qt Creator as root ?



  • @SGaist : As you said I write these code :
    hgh1@ubuntu:~$ cd /home/hgh1/Qt5.4.1/Tools/QtCreator/bin
    hgh1@ubuntu:~/Qt5.4.1/Tools/QtCreator/bin$ ./qtcreator.sh -noload Welcome
    No tool chain set from kit "Desktop".
    No tool chain set from kit "Desktop".
    and Qt not load. just show a black display ( when not root)
    How Can I fix my Qt?


  • Lifetime Qt Champion

    You did not install Qt. You only installed QtCreator.
    You have to install Qt itself. It looks like you used the online installer, then call /home/hgh1/Qt5.4.1/MaintenanceTool (not as root!), select "Add or remove components" and select Qt 5.5 ("Desktop gcc 64-bit" if you have a 64bit Ubuntu).

    Design is different because you are logged on as normal user but start QtCreator as root.


  • Lifetime Qt Champion

    And please write QtCreator if you mean the QtCreator IDE and not Qt. Qt is a C++ framework.



  • Sorry. yes I mean Qt creator IDE 5 for 32 bit Ubuntu system , And also I said I installed Qt4.8.3 and attache that qmake to Qt IDE. Since yesterday it was damaged. Before that I worked with my IDE as well.
    My IDE is running on VM ware on my PC.


Log in to reply