QtCreator(Qt5.5 +MinGW 32 bit) problem with building subdirs on Windows 10



  • Hello,

    I tried to make a new subtree project which contains only this lines.

    TEMPLATE = subdirs
    SUBDIRS = cryptopp563 \
             tumorProfil
    CONFIG += ordered
    

    I can build each project individually, but I can't run them together:

    This is the console output:

    cd cryptopp563/ && ( test -e Makefile || D:/qt5.5/5.5/mingw492_32/bin/qmake.exe C:/Users/Slavik/Documents/TumorProfil/cryptopp563/cryptopp563.pro -spec win32-g++ CONFIG+=debug -o Makefile ) && D:/qt5.5/Tools/mingw492_32/bin/mingw32-make -f Makefile 
          0 [main] sh 7552 sync_with_child: child 5396(0x1B4) died before initialization with status code 0xC0000142
         23 [main] sh 7552 sync_with_child: *** child state waiting for longjmp
    makefile:39: recipe for target 'sub-cryptopp563-make_first-ordered' failed
    /usr/bin/sh: fork: Resource temporarily unavailable
    mingw32-make: *** [sub-cryptopp563-make_first-ordered] Error 128
    18:22:40: The process "D:\qt5.5\Tools\mingw492_32\bin\mingw32-make.exe" exited with code 2.
    Error while building/deploying project project (kit: Desktop Qt 5.5.1 MinGW 32bit)
    When executing step "Make"
    18:22:40: Elapsed time: 00:01.
    

    Can somebody help me?


  • Lifetime Qt Champion

    Hi,

    Not a direct answer but are you experiencing the same error if you follow this blog post about setting up an ordered subdir project ?



  • Hello,

    the problem is not related to ordered building.

    The QtCreator can not execute fork() for unknown reasons. I changed the project to use dependencies but I still get the same error.


  • Lifetime Qt Champion

    Qt Creator 3.6 ?



  • Qt Creator 3.5.1, from mingw package



  • Also, installed QtCreator 3.6.0 but I still get the same error on my windows machine. Linux set-up is able to compile and run everything.



  • Hi, I see in your console output: status code 0xC0000142 that could be because you have an antivirus program running.

    Or if you don't, it could be some other app injecting an AppInit .dll; to see which try running Autoruns check the Appinit tab when compiling.



  • I had Windows Defender running, I disabled it. Still no luck. Also I checked with Autoruns, nothing appears when I run QtCreator. Appinit only shows some entries from nvidia.



  • I have the same problem, has anyone found a solution yet?

    This only seems to occur on building android, windows applications run fine.



  • This post is deleted!

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.