QMediaPlayer and GStreamer plug-ins

  • Hello!
    A couple of days ago I started working with QMediaPLayer (from Qt 5.5.1) on Ubuntu 15.10 x64.
    And I cannot resolve a problem related to play audio.
    Here are the errors from the output window:

    GStreamer; Unable to pause - "file:///home/slava/Music/02. Above & Beyond feat. Zoe Johnston - We're All We Need.mp3"
    Error: "Your GStreamer installation is missing a plug-in."
    Warning: "No decoder available for type 'application/x-id3'."

    And dialogs which appear when I open audio:

    https://www.dropbox.com/s/8x8271jwm7d7hrz/Screenshot from 2016-01-07 12-44-17.png?dl=0
    https://www.dropbox.com/s/0ibpzg9crmso3gk/Screenshot from 2016-01-07 12-44-36.png?dl=0

    I've looked through many topics, related to GStreamer and plug-ins, and I've executed many commands on the terminal. There is no result, since I'm getting the same output as above.

    Thanks for any help and suggestion!

  • @Suares
    Hi and welcome.
    Did you try this?

    sudo apt-get install gstreamer0.10-ffmpeg

  • Hello @Ratzz, thank you for reply.
    I did this before and I've just done it again:

    gstreamer0.10-ffmpeg is already the newest version.
    The following packages were automatically installed and are no longer required:
      brasero-cdrkit libchromaprint0 libde265-0 libfluidsynth1 libgtkglext1
      libilmbase12 libmpg123-0 libopencv-calib3d2.4v5 libopencv-contrib2.4v5
      libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4v5
      libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5
      libopencv-video2.4v5 libopenexr22 libsrtp0
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Maybe I have a conflict in the system with other installed libraries or softwares. Puzzle...

  • Lifetime Qt Champion


    I'm not sure but IIRC, 5.5.1 might be using GStreamer 1.0.

  • Hello, @SGaist! Thank you for your assistance.

    I installed GStreamer1.0 using

    sudo add-apt-repository ppa:gstreamer-developers/ppa
    sudo apt-get update
    sudo apt-get install gstreamer1.0*

    But I'm getting the same error.

  • Lifetime Qt Champion

    Try running gst-inspect id3demux

    [edit: fixed application name SGaist]

  • Hi, @SGaist!
    Now things go well.
    I've just used a brute force method. And it helped me.
    I think a bad plugin was missed in the system. But I'm not sure. Here is a list of the latest commands:

    106  apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev
    107  sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev
    108  sudo apt-get install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev
    109  sudo apt-get install libgstreamer1.2-dev libgstreamer-plugins-base1.2-dev
    110  sudo apt-get install gstreamer0.10-plugins-bad
    111  sudo apt-get install gstreamer1.0-plugins-bad
    112  sudo apt-get install ubuntu-restricted-addons
    113  sudo apt-get install gstreamer0.10-plugins-bad-multiverse
    114  sudo apt-get install gstreamer1.0-plugins-bad-multiverse

    As for get-inspect command:

    No command 'get-inspect' found, did you mean:
    Command 'gst-inspect' from package 'gstreamer-tools' (main)
    get-inspect: command not found

    Thanks for all :)

  • Lifetime Qt Champion

    Whoops sorry, I meantget-inspect. I've fixed my other post.

    You're welcome :)

    Since you have it working now, please mark the thread as solved using the "Topic Tool" button so other forum users may know a solution has been found :)

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.