Getting Error (0xc000001d) on an old processor. Need to compile without SSE2. But how?



  • Hi!

    I have written a program for an old, sort of embedded Machine, which runs WindowsXP x86 SP3 on a "VIA Nehemiah" processor.

    I complie from Windows10 x64 on an Intel i7.
    When I run the program in a VirtualBox with WindowsXP x86 it runs fine and it looks almost exactly like in Windows 10. So the problem has to be some missing instruction sets on the VIA processor.

    I am googling my ass off, on how to compile without the SSE2 instruction set, because the VIA Nehemiah only knows MMX and SSE(1).
    See: http://www.cpu-world.com/Compare/748/Intel_Core_i7_i7-4770K_vs_VIA_C3_1_GHz_(C3-1.0AGHz_EBGA).html#specs

    There should be a "-no-sse2" option for qmake, but what would be the correct syntax?

    qmake myproject.pro -no-sse2
    

    says "unknown option"

    mingw32-make -no-sse2
    

    does something, but does not output any files. It only creates a Debug and Release folder.

    For QtCreator (which is my preferred way to compile) i have found an

    OPTION -= sse2
    

    for the .pro file... it compiles without messages, but the old machine keeps on saying:

    The application failed to initialize properly (0xc000001d).
    Click on OK to terminate the application.
    

    Is it possible to compile from my machine, leaving out some instruction sets the old machine does not understand? How?

    Tanks for any hints!

    Cheers and a happy new year!

    Mr. Floppy


  • Lifetime Qt Champion

    Hi
    It would be while compiling all of Qt.
    Making your own version of Qt.
    Then via configure you can disable
    http://doc.qt.io/qt-4.8/configure-options.html



  • Thanks for the super fast reply!
    I guess than there is no way around compiling another version of Qt then?

    Fine. The worst thing that can happen is that I will learn something on the way ;)

    I will mark this one as solved, but if somebody knows of a way without recompiling Qt, feel free to let me know anyways!


  • Lifetime Qt Champion

    @Mr.Floppy
    I'm afraid that recompile is the only options (as far as i know) unless you can find an
    already made binary packet.
    Maybe there is some sort of hax if u not really using the features requiring it but
    not seen any :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.