configure is ignoring me (OS X 10.11)



  • The qt-everywhere source build is breaking for me on OS X with Xcode 7.2 on thing I don't need.

    My first problem was that somewhere in the build of QtWebEngine it was trying to link with zlib and couldn't figure out how to use the .tbd file that resides in /...<deep Xcode path>.../MacOSX10.11.sdk/usr/lib. So I threw everything out and passed --qt-zlib and --continue to configure. The result?

    zlib ................... yes (system library)

    and it of course stopped on the same error. I ended up making a link to /usr/lib (where the actual library is), which worked around that particular problem, but I was getting a load of other similar link errors, so I tried again with --skip webengine. I can't actually find the result of this in qtbase/config.summary but it sure is still exploding on the same link errors in QtWebEngine.

    This is my current configure line:
    ``./configure -opensource -confirm-license -no-qml-debug -no-openssl -no-compile-examples -silent -optimized-qmake -securetransport -nomake tools -nomake examples -release -qt-zlib -skip WebEngine```

    Ideas?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.