[SOLVED] module "QtQuick" is not installed



  • I have a Qt project and I would like to deploy it to Raspberry 2.
    This project works with Raspberry 1.

    I have a new Debian Jessie and a Raspberry 2 with Raspbian Jessie. I downloaded the qt source (5.5.1) and I have cross compiled it.
    I use QtCreator 3.5.1and I can build and deploy my project to the raspberry but I got

    file:///home/pi/qtdebug/qml/qml_controls/main.qml:1:1: module "QtQuick" is not installed
    import QtQuick 2.3

    I checked the library dependencies

    ldd qml_controls
    linux-vdso.so.1 (0x7ea44000)
    /usr/lib/arm-linux-gnueabihf/libarmmem.so (0x76f3c000)
    libftd2xx.so => /usr/local/lib/libftd2xx.so (0x76f07000)
    libQt5Quick.so.5 => /usr/local/qt551pi/lib/libQt5Quick.so.5 (0x76c1b000)
    libQt5Gui.so.5 => /usr/local/qt551pi/lib/libQt5Gui.so.5 (0x767d5000)
    libQt5SerialPort.so.5 => /usr/local/qt551pi/lib/libQt5SerialPort.so.5 (0x767be000)
    libQt5Qml.so.5 => /usr/local/qt551pi/lib/libQt5Qml.so.5 (0x76445000)
    libQt5Network.so.5 => /usr/local/qt551pi/lib/libQt5Network.so.5 (0x7635f000)
    libQt5Core.so.5 => /usr/local/qt551pi/lib/libQt5Core.so.5 (0x75e6c000)
    libGLESv2.so => /opt/vc/lib/libGLESv2.so (0x75e3b000)
    libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0x75e13000)
    libstdc++.so.6 => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 (0x75d37000)
    libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0x75cbb000)
    libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0x75c8e000)
    libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0x75b51000)
    libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0x75b3e000)
    librt.so.1 => /lib/arm-linux-gnueabihf/librt.so.1 (0x75b27000)
    libpng12.so.0 => /lib/arm-linux-gnueabihf/libpng12.so.0 (0x75af6000)
    libz.so.1 => /lib/arm-linux-gnueabihf/libz.so.1 (0x75acf000)
    /lib/ld-linux-armhf.so.3 (0x54b42000)
    libEGL.so => /opt/vc/lib/libEGL.so (0x75aa6000)
    libbcm_host.so => /opt/vc/lib/libbcm_host.so (0x75a88000)
    libvchiq_arm.so => /opt/vc/lib/libvchiq_arm.so (0x75a7a000)
    libvcos.so => /opt/vc/lib/libvcos.so (0x75a67000)

    I think it is ok.
    Could somebody help me? :S

    Thanks!



  • I solved the problem. Somehow in the qml directory the "qmldir" file was missing.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Glad you found out and thanks for sharing !

    To mark your thread as solved please us the "Topic Tool" button. It will keep the titles clean (the title update technique was used with an older version of the forum software)



  • Hi Wolfy & S Gaist,

    Actually I am facing the same problem, as you have found the way to solve it could you please post the the steps to do. it would be really great full help to me.

    Regardsa
    Prashant



  • Hello,

    I will just brief what I am trying to do, I installed Qt5.5.1 on Open Suse 12.1 32 bit machine and compile and run the flat style example from qt examples using qt creator so it works great now my goal is to develop the qt quick application and deploy it several other Linux distribution, So I have gone through several blog post and google material for how to deploy qt application with shared library as I could not statically compiled cause I am using very old Linux distribution due to some reason, so by googling some how I came to this step now and hoping for the best for my efforts to get the flat example run with shared library on other machine too.

    So any help will be really boost my work with Qt quick application development.

    Regards
    Prashant



  • Hello,

    I have tried one more way to proceed further if you know anything about it please look,
    I create on script to set some path to run the application as

    #!/bin/sh
    export LD_LIBRARY_PATH=/opt/flat/lib
    export QML_IMPORT_PATH=/opt/flat/lib/qml
    export QML2_IMPORT_PATH=/opt/flat/lib/qml
    export QT_QPA_PLATFORM_PLUGIN_PATH=/opt/flat/lib/plugins/platforms
    ./flat

    =============================================

    When I run the script I got below errors as ...

    linux-koto:/opt/flat/bin # ./test.sh
    QML debugging is enabled. Only use this in a safe environment.
    QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
    Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile 0)
    ./test.sh: line 6: 24866 Aborted ./flat

    Kindly help me if any one know how to resolve this .

    Regards
    Prashant



  • Hi Prashanth,

    I am facing the exact same error as yours. And I am also using the similar script to set the library and qml paths and to run the application. Are you able to solve the issue?



  • Seems like this is anything BUT solved!
    My app has this problem, so I used the example project "touchinteraction", added a few of my custom controls, added the same QML module imports, then deployed it to android. It all works.
    import QtQuick 2.4
    import QtQuick.Controls 1.3
    import QtQuick.Window 2.2
    import QtQuick.Controls.Styles 1.2
    import QtQuick.Controls.Private 1.0
    import QtQuick.Layouts 1.1

    So now I am trying to find what is different between the deployment for the modified example and my own application.
    The libs.xml seems to be the culprit. In the example,
    C:\Qt\Qt5.5.1\Examples\Qt-5.5\quick\build-touchinteraction-Android_for_armeabi_v7a_GCC_4_9_Qt_5_5_1-Debug\android-build\res\values\libs.xml

    In the xml sections, "bundled in lib", and "bundled in assets", there is all kinds of relevent looking stuff.
    File is 38kB compared to 3kB generated in my own project.

    Using the template, I tried to mimic this content in my own libs.xml. But so far no good.
    The documentation is good, if sparse.

    Anyone found the magic bullet?



  • I solved this, but had to use command line tools. I use a subdirs project with several libraries and for some reason this leads to an incorrect qml-root-path being written to the json file.

    1. Edit the qml-root-path in the json file.
    2. check that the application.so has been copied to the correct target location (e.g. BUILD\android-build\libs\armeabi-v7a
    3. run androiddeployqt from the command line with arguments for the ant path and the json path.
    4. use adb to install.

    FWIW, I am now wrestling with getting the same project running on iOS. I hit the same problem, used macdeployqt to deploy the QML modules, - but this time it still complains that modules are not installed. To be continued.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.