-qt-xcb won't work



  • I tried to pass qt-xcb parameter to configure Qt 5.5.1 and it doesn't work.

    What are the steps to make -qt-xcb available to configure, what are dependencies? I tried to find a solution, but without success.


  • Lifetime Qt Champion

    Hi,

    What errors are you currently getting ? What OS are you building on ?



  • @SGaist I am trying to build qt 5.5.1 on my Ubuntu host machine for armhf target machine.


  • Lifetime Qt Champion

    What errors are you getting exactly ?



  • @SGaist

    • Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
      Warning: Disabling pkg-config since PKG_CONFIG_SYSROOT_DIR is not set.
      The test for linking against libxcb failed!
      Use of pkg-config is not enabled, maybe you want to pass -force-pkg-config?
      You might need to install dependency packages for libxcb.
      See src/plugins/platforms/xcb/README.

    I don't understand this 'You might need to install dependency packages for libxcb'. Dependency packages on my virtual host machine?

    If I am right I need to add path to arm libxcb lib and include folder to make it work? Or there is more to do than what I wrote? Please describe what ./configure expecting to be done for xcb before add -qt-xcb argument to it, what things need to be met?

    Is it possible to compile Qt5 and run app with LinuxFB instead of using XCB? What are advantages and disadvantages?



  • @SGaist I solved problem with xcb! But now it tells me something like this when trying to deploy and run my app on Beaglebone Black device:

    No protocol specified
    QXcbConnection: Could not connect to display :0.0


  • Lifetime Qt Champion

    Do you have a X server running on your board ?

    In any case, you can use the other backends of Qt if you don't. You have more details about them here



  • @Zola I have the same problem. How did you solve this problem?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.