How can I build qtdeclarative independent?



  • I download qt library.
    I have got folder - qt5.
    That folder has qtdeclarative subfolder and I want to compile/build only this subfolder.
    I try to do this:
    $ make
    but I get ../../include/QtQml/5.5.0/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:49:31: fatal error: private/qobject_p.h: No such file or directory
    #include <private/qobject_p.h

    What have I done wrong?


  • Lifetime Qt Champion

    Hi,

    You need to have at least qtbase built before building qtdeclarative.



  • Yeah, thx.
    But I got next error when I compile qtbase:

    text/qharfbuzzng.cpp:169:5: error: ‘HB_SCRIPT_CAUCASIAN_ALBANIAN’ was not declared in this scope
    HB_SCRIPT_CAUCASIAN_ALBANIAN,
    ^
    text/qharfbuzzng.cpp:170:5: error: ‘HB_SCRIPT_BASSA_VAH’ was not declared in this scope
    HB_SCRIPT_BASSA_VAH,
    ^
    text/qharfbuzzng.cpp:171:5: error: ‘HB_SCRIPT_DUPLOYAN’ was not declared in this scope
    HB_SCRIPT_DUPLOYAN,
    ^
    text/qharfbuzzng.cpp:172:5: error: ‘HB_SCRIPT_ELBASAN’ was not declared in this scope
    HB_SCRIPT_ELBASAN,
    ^
    text/qharfbuzzng.cpp:173:5: error: ‘HB_SCRIPT_GRANTHA’ was not declared in this scope
    HB_SCRIPT_GRANTHA,
    ^
    text/qharfbuzzng.cpp:174:5: error: ‘HB_SCRIPT_PAHAWH_HMONG’ was not declared in this scope
    HB_SCRIPT_PAHAWH_HMONG,
    ^
    text/qharfbuzzng.cpp:175:5: error: ‘HB_SCRIPT_KHOJKI’ was not declared in this scope
    HB_SCRIPT_KHOJKI,
    ^
    text/qharfbuzzng.cpp:176:5: error: ‘HB_SCRIPT_LINEAR_A’ was not declared in this scope
    HB_SCRIPT_LINEAR_A,
    ^
    text/qharfbuzzng.cpp:177:5: error: ‘HB_SCRIPT_MAHAJANI’ was not declared in this scope
    HB_SCRIPT_MAHAJANI,
    ^
    text/qharfbuzzng.cpp:178:5: error: ‘HB_SCRIPT_MANICHAEAN’ was not declared in this scope
    HB_SCRIPT_MANICHAEAN,
    ^
    text/qharfbuzzng.cpp:179:5: error: ‘HB_SCRIPT_MENDE_KIKAKUI’ was not declared in this scope
    HB_SCRIPT_MENDE_KIKAKUI,
    ^
    text/qharfbuzzng.cpp:180:5: error: ‘HB_SCRIPT_MODI’ was not declared in this scope
    HB_SCRIPT_MODI,
    ^
    text/qharfbuzzng.cpp:181:5: error: ‘HB_SCRIPT_MRO’ was not declared in this scope
    HB_SCRIPT_MRO,
    ^
    text/qharfbuzzng.cpp:182:5: error: ‘HB_SCRIPT_OLD_NORTH_ARABIAN’ was not declared in this scope
    HB_SCRIPT_OLD_NORTH_ARABIAN,
    ^
    text/qharfbuzzng.cpp:183:5: error: ‘HB_SCRIPT_NABATAEAN’ was not declared in this scope
    HB_SCRIPT_NABATAEAN,
    ^
    text/qharfbuzzng.cpp:184:5: error: ‘HB_SCRIPT_PALMYRENE’ was not declared in this scope
    HB_SCRIPT_PALMYRENE,
    ^
    text/qharfbuzzng.cpp:185:5: error: ‘HB_SCRIPT_PAU_CIN_HAU’ was not declared in this scope
    HB_SCRIPT_PAU_CIN_HAU,
    ^
    text/qharfbuzzng.cpp:186:5: error: ‘HB_SCRIPT_OLD_PERMIC’ was not declared in this scope
    HB_SCRIPT_OLD_PERMIC,
    ^
    text/qharfbuzzng.cpp:187:5: error: ‘HB_SCRIPT_PSALTER_PAHLAVI’ was not declared in this scope
    HB_SCRIPT_PSALTER_PAHLAVI,
    ^
    text/qharfbuzzng.cpp:188:5: error: ‘HB_SCRIPT_SIDDHAM’ was not declared in this scope
    HB_SCRIPT_SIDDHAM,
    ^
    text/qharfbuzzng.cpp:189:5: error: ‘HB_SCRIPT_KHUDAWADI’ was not declared in this scope
    HB_SCRIPT_KHUDAWADI,
    ^
    text/qharfbuzzng.cpp:190:5: error: ‘HB_SCRIPT_TIRHUTA’ was not declared in this scope
    HB_SCRIPT_TIRHUTA,
    ^
    text/qharfbuzzng.cpp:191:5: error: ‘HB_SCRIPT_WARANG_CITI’ was not declared in this scope
    HB_SCRIPT_WARANG_CITI
    ^
    In file included from ../../include/QtCore/qglobal.h:1:0,
    from kernel/qt_gui_pch.h:44:
    ../../include/QtCore/../../src/corelib/global/qglobal.h:692:36: error: static assertion failed: QChar::ScriptCount == sizeof(_qtscript_to_hbscript) / sizeof(_qtscript_to_hbscript[0])

    gcc --version
    gcc (Ubuntu 5.3.0-3ubuntu1~14.04) 5.3.0 20151204

    g++ --version
    g++ (Ubuntu 5.3.0-3ubuntu1~14.04) 5.3.0 20151204


  • Lifetime Qt Champion

    What parameters did you pass to configure ?



  • I haven't passed any parameters to the configure.


  • Lifetime Qt Champion

    Which version of qmake did you use ?



  • QMake version 3.0
    Using Qt version 5.2.1 in /usr/lib/x86_64-linux-gnu



  • I built qt om my old ubuntu and everythink is OK. Thanks.


  • Lifetime Qt Champion

    Were you trying to build a more recent version of Qt using the on from your distribution ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.