Compilation error: [sub-lib-make_first-ordered] Error 1



  • Hi guys,

    I've been trying to compile this project https://github.com/KDAB/integrating-qq2-with-opengl, but it gives the following compilation error:

    [sub-lib-make_first-ordered] Error 1
    

    Environment: Windows 10, Qt Creator 3.5.1 (opensource), Desktop Qt 5.5.1 MinGW 32 bit.

    Any idea how to solve this issue?


  • Moderators

    What errors do you get before that line?



  • When compiling with MinGW the only error that shows is the mentioned one ":-1: error: [sub-lib-make_first-ordered] Error 1". No more details and no other errors.

    I tried to compile the same project with MSVC2013 64 bit compiler. The error is different this time: ":-1: error: dependent '..\underlay..\lib\librenderlib.a' does not exist."

    Compiling a Qt project is really a hard task...


  • Moderators

    I tried on Linux:
    qmake
    make
    Worked just fine.


  • Moderators

    On Windows it fails with:
    No rule to make target integrating-qq2-with-opengl-master/underlay/../lib/librenderlib.a

    Could be due to missing OpenGL libs/headers.



  • I found out why the error "[sub-lib-make_first-ordered] Error 1" appears. I installed Qt in "C:\Program files" directory and the space in the name of the folder causes troubles:

    'C:/Program' is not recognized as an internal or external command, operable program or batch file.
    

    So I reinstalled Qt in different directory with no spaces in it. Now I get exactly the same error as jsulm:

    No rule to make target '../Debug/underlay/../lib/librenderlib.a', needed by 'debug\underlay.exe'. 
    

  • Lifetime Qt Champion

    Hi,

    You were hit by the good old "whitespace in path" problem. On Windows you should either use paths without spaces or use the old 8.3 path notation.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.