QtWebEngine qmake error: unkown module: webchannel



  • I am trying to get qt webengine running on my laptop for the first time, but can't seem to build it. I am following the instructions from here:

    https://wiki.qt.io/QtWebEngineHowToTry

    On the last few steps, I had to run "qmake -r" on the qtwebengine directory. This is the output:

    ==========================================
    SSL............................... Using system NSS
    ICU............................... Using internal copy (Default, force system ICU with WEBENGINE_CONFIG += use_system_icu)
    FFMPEG............................ Using internal copy (Default, force system FFMPEG with WEBENGINE_CONFIG += use_system_ffmpeg)
    Proprietary codecs (H264, MP3).... Not enabled (Default, enable with WEBENGINE_CONFIG += use_proprietary_codecs)
    Reading /home/kevin/workspace/qtwebengine/src/src.pro
    Reading /home/kevin/workspace/qtwebengine/src/core/core.pro
    Reading /home/kevin/workspace/qtwebengine/src/core/core_gyp_generator.pro
    Project ERROR: Unknown module(s) in QT: webchannel

    This error happened right after I installed WebKitGtk+ from here (http://trac.webkit.org/wiki/BuildingGtk) and ran "Tools/gtk/install-dependencies" and "Tools/Scripts/update-webkitgtk-libs". Before I installed WebKitGtk+, qmake would terminate at a later point.

    (I installed WebKitGtk+ because, previously, running "qmake -r" on the qtwebengine directly resulted in an "unmet dependency: harfbuzz" error that I tried to fix on my own via google, and the WebKitGtk+ page was the only lead I could find that would supposedly fix that issue... big mistake!).

    I am running on a (mostly freshly reformatted) Ubuntu 15.04 laptop. I installed qt5 via apt-get install, but apparently I have both qt4 and qt5 plugins installed, as well as qtchooser (I'm guessing from the WebKitGtk+ installation scripts).

    Here is the output of "qmake --version":

    ================================
    QMake version 3.0
    Using Qt version 5.4.1 in /usr/lib/x86_64-linux-gnu

    I've spent the past 3days or so trying to fix this error, but have no idea what to do next. Any help would be greatly appreciated, as I'm excited to try out qt webengine!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Looks like your missing the QtWebchannel module



  • Thanks SGaist. I did a little more investigating, and it turns out downloading qt 5.5.0 from http://download.qt.io/official_releases/qt/ fixed all the build issues. I'm not sure how to mark this as solved, is a mod suppose to do that for me?


  • Lifetime Qt Champion

    You're welcome !

    No, you can do it yourself using the "Topic Tool" button :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.