Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt 5.5.1 30% slower than Qt 5.5.0 ?



  • Hi,

    after switching from Qt 5.5.0 to Qt 5.5.1 (both MSVC2013 64bit) the graphic animations of the same Qt Windows 7 64bit desktop application are running 30% slower.

    The animation is drawing in a QWidget via QPainter and QFont.

    Anyone know what the problem might be?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Since it looks like it might be a severe regression. I'd recommend posting this question to the interest mailing list. You'll find there Qt's developers/maintainers (this forum is more user oriented)



  • Hi,

    thanks for the welcome and your recommendation to post this topic to the Qt interest mailing list. I'll do that.

    Is there anybody else who noticed a slow down of his application after updating from Qt 5.5.0 to Qt 5.5.1?



  • Meanwhile after further testing I'm not sure if its only an graphic issue. Because a basic QWidget / QPainter test application did not show any slow down with Qt 5.5.1. So it might be a deeper issue.

    All I can say is that my application runs 30% slower with QT 5.5.1 than with Qt 5.5.0.

    So I downloaded both Qt versions again and made a clean install. And after recompiling the Qt 5.5.0 and Qt 5.5.1 versions of my application both ran slow !!

    So I checked the files from the new downloaded Qt 5.5.0 an saw that there are new files in it: For instance Qt5Core.dll and Qt5Cored.dll are from 23 October 2015 !

    So I went back to the initial QT 5.5.0 release with Qt5Core.dll and Qt5Cored.dll from date 11. August 2015. And the speed was there again !

    There is definitely something wrong with the new Qt 5.5.1 release. But I'm not an Qt expert to find out which Qt module does the slow down.


  • Lifetime Qt Champion

    In that case I'd recommend posting your findings and question on the interest mailing list You'll find there Qt's developers/maintainers (this forum is more user oriented)



  • @molter The same for me with no graphic animations, but ordinary qml controls. Did you figure out anything new? Patch or smth?


Log in to reply