Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

error compliling qlibinputpointer.cpp



  • Hi all,

    I'm getting an error when compiling qlibinputpointer.cpp

    g++ -c -include .pch/Qt5PlatformSupport -pipe -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -O2 -fPIC -fvisibility=hidden -fvisibility-inlines-hidden -std=c++0x -fno-exceptions -Wall -W -D_REENTRANT -DQT_NO_TSLIB -DQT_NO_CAST_FROM_ASCII -DMESA_EGL_NO_X11_HEADERS -DQT_NO_XKBCOMMON_EVDEV -DQT_LIBINPUT_VERSION_MAJOR= -DQT_LIBINPUT_VERSION_MINOR= -DQT_BUILD_PLATFORMSUPPORT_LIB -DQT_BUILDING_QT -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x050000 -DQ_FONTCONFIGDATABASE -DQT_NO_EXCEPTIONS -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_DBUS_LIB -DQT_CORE_LIB -I. -isystem /usr/local/include -isystem /usr/include/freetype2 -Iaccessibility -I../3rdparty/atspi2 -Ilinuxaccessibility -Idbusmenu -I../gui/kernel -Idbustray -I../gui/kernel -I../../include -I../../include/QtPlatformSupport -I../../include/QtPlatformSupport/5.5.0 -I../../include/QtPlatformSupport/5.5.0/QtPlatformSupport -isystem /usr/include/libdrm -I../../include/QtCore/5.5.0 -I../../include/QtCore/5.5.0/QtCore -I../../include/QtGui/5.5.0 -I../../include/QtGui/5.5.0/QtGui -I../../include/QtGui -I../../include/QtDBus -I../../include/QtCore -I.moc -isystem /usr/include/libdrm -I../../mkspecs/linux-g++ -o .obj/qlibinputpointer.o input/libinput/qlibinputpointer.cpp
    input/libinput/qlibinputpointer.cpp:94:31: Error: operator '==' has no left operand
    #if QT_LIBINPUT_VERSION_MAJOR == 0 && QT_LIBINPUT_VERSION_MINOR <= 7
    ^
    make[3]: *** [.obj/qlibinputpointer.o] Error 1


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What parameter did you pass to configure ?
    What linux flavor are you building for ?
    What does pkg-config --modversion libinput return ?



  • @SGaist:
    I'm on CentOS 7.1 (64bit)
    my config line is: ./configure -v --prefix=/opt -opensource -confirm-license -qt-xcb -optimized-qmake -no-nis -libinput -L/usr/local/lib -I/usr/local/include -linput -levdev

    The pkg-config output is:
    # pkg-config --modversion libinput Package libinput was not found in the pkg-config search path. Perhaps you should add the directory containing libinput.pc to the PKG_CONFIG_PATH environment variable No package libinput found

    hmm ... so seems the compiler can't find the libinput.pc ... I'll set the PKG_CONFIG_PATH to /usr/local/lib ...


  • Lifetime Qt Champion

    That's it yes, however I wonder why the test succeeded since it can't find the library.


Log in to reply