[Solved] iOS, xCode 7 and Qt



  • After many hours on trying to compile my app for iOS (the last time was in july), now I see that Qt 5.5 does not support xCode 7. Can you confirm it?
    Someone have an idea on when Qt will support it?


  • Qt Champions 2016

    What is your problem? I am already using Qt 5.5 + XCode7 to compile iOS application.



  • How? I can build a hello world app with xCode but qtcreator does not detect the kit and if I try to add it I never see my app in my iPad...


  • Qt Champions 2016

    @mrdebug Detect the kit? or detect the device?

    I just upgrade from Qt 5.4 to Q5.5 , then upgrade XCode from 6 to 7. There has problem with my application but should be not related to your case.

    What if you just run qmake in Qt Creator, then open the generated .xcodeproj by XCode 7, check can it be deployed to your iPad via XCode?



  • Have you got iOS 9 in your device?
    My program works in iPhone 6s - iPhone 6s / iOS 9.0 simulator.

    If I open my progject with Code, my iPad is listen as inelegible device in Xcode.
    If I go in Xcode -> product -> Desctination -> my iPad to select my device, when I try to run my app I obtain in Xcode the error

    "The run destination iPad ... is not valid for running the scheme ..." iPad ... doesn't support any of ... app's architecture, You can add .... armv7s architecture to ... build setting.


  • Qt Champions 2016

    My device is iPad Mini 2 + iOS 9. It is working fine.

    Since you could not deploy by XCode. So the problem is on XCode , not on Qt/Qt Creator.

    Did you installed iOS9 SDK?

    XCode -> Preferences -> Download

    If it is available to download, just download it.



  • I'm not sure to have it. In Donwload section i find iOS Simulator ad documentation but not related to sdk.
    Pay attention, I can made an app for my iPad with Xcode without any problem.



  • This may be useful, or link to something useful: https://bugreports.qt.io/browse/QTCREATORBUG-15147

    (Personally, I only just upgraded to xcode6 :^)



  • Solved by upgrading Qt Creator to 3.5.0
    Many thanks.


Log in to reply