Qtcreator 3.5 compiler problem



  • Hello everyone,
    I'm looking for help here since I didn't find from where my problem come from.
    The problem is that I downloaded QtCreator and Qt5.5.0.
    But when I have to configure Qtcreator, in tools->options->Compiler & Execution-> Kits i can't define any compiler, the button is grey. I already put a compiler in Compiler & Execution -> Compilers but it seems that the compiler isn't recognized.

    I didn't find the way to put an image, do I have to use Markdown?

    Thanks all, and have a great day!

    Edit : It seems that I don't have MSVC 2008 and that can be the origin of the problem.
    I'll download it then come back here.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Indeed, if you install a MSVC build of Qt you need to also have the corresponding Visual Studio installed (you can't mix libraries for one version of Visual Studio with another one, the compliers are not compatible one with the other)

    Also, unless you're locked to that version of Visual Studio, you should rather use a more recent version.



  • Well thanks for your response. I found a way to make a clean install.
    I just uninstalled all the things I downloaded and installed qt 5.0.2 with minGW 4.7 and all worked perfectly.
    One of my big problem, in fact, is that I didn't have root acces to install all the things I needed. But now it's perfect!
    And i also installed Visual Studio 2013 btw :)

    Thanks buddy, have a great day!


  • Lifetime Qt Champion

    You're welcome !

    Since you have it working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)

    Also, while browsing the forum, if you come across answer(s) that you find useful, please consider up-voting them. That will make them more visible for other visitors.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.