[SOLVED]macdeployqt isn't adding all frameworks in .app file



  • I have qt project on mac osx yosemite 10.10.4 which needs qt libs/frameworks . Whenever I run macdeployqt to add necessary files in the .app it gives me error, but doesn't say for which path or file.

    Here is the output -

    tushar-iMac:bin tushar$ macdeployqt /Users/tushar/Documents/Repo/QT/trunk/project-1/bin/MyApp.app
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    ERROR: no file at ""
    tushar-iMac:bin tushar$

    I just can't figure out,what the error is. The .app size is way less than intended & because of the missing frameworks the app doesn't run at all.

    Thanks in advance.



  • Hi,

    Did you try to call macdeployqt with --verbose=2 this property give you more debug information about macdeployqt.

    I using in my app QML and I have the same problem but all frameworks was copied but QML plugins not. You can read my post maybe this help to you. Also I show there how to use macdeployqt from qtcreator.



  • Thanks for the help.

    But the real reason was that, I was using wrong version of QT for my project. My project supports QT version upto 5.4 & I was using 5.5. After downgrading all works fine now.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.