Where do I actually get the src files for 5.5?



  • I need to get the plugins for QSQLIBASE but my installation doesn't have the src folder like all the tutorials (http://doc.qt.io/qt-5/sql-driver.html).

    I used the web installer, and i've tried installing with "source components" selected but it installed a bunch of other stuff that I don't recognise from any of the tutorials.

    Am I being a complete idiot? Where do I actually get the "plugin" source files I need?

    I go here: http://doc.qt.io/qt-5/gettingstarted.html and it tells me I can install the tools (what I did) or build them myself (which it turns out I need to do) then goes into detail about. It points towards the downloads page, and says I can download "Qt in source code form (needed only if you want to build the framework and tools yourself)"

    Which option lets me do that? I've downloaded gigabytes of data over a mobile connection trying to find the right file!

    Thanks!


  • Lifetime Qt Champion

    Hi,

    If you check the source components from the installer, you should have got Qt's complete sources in a Src folder. The drivers code is in qtbase/src/plugins/sqldrivers/ibase/
    You can use the command line from there or Qt Creator to build the plugin.



  • Wow, I feel like an idiot, I was looking for a src/plugins not src/qtbase,/src/plugins


  • Lifetime Qt Champion

    No worries, the tree structure is pretty big with Qt



  • Hmm, calling:

    qmake "INCLUDEPATH+=C:\Program Files\Firebird\Firebird_2_5\include" "LIBS+=-lfbclient" ibase.pro

    then nmake, but it's saying it can't find the ibase.h:

    c:\qt\qt5.5.0\5.5\src\qtbase\src\plugins\sqldrivers\ibase../../../sql/drivers/i
    base/qsql_ibase_p.h(50) : fatal error C1083: Cannot open include file: 'ibase.h'
    : No such file or directory

    But ibase.h is definitely in the C:\Program Files\Firebird\Firebird_2_5\include directory.


  • Lifetime Qt Champion

    You should quote the path itself not INCLUDEPATH.

    Note that since you have a space in that path, I think the linking will fail. If so I'd recommend using the good old 8.3 name format for Program Files (something like PROGRA~1).



  • That did it! Program Files space is always a pain. Now I'm getting:

    LINK : fatal error LNK1181: cannot open input file 'fbclient.lib'

    which isn't surprising given fbclient.lib doesn't exist. I'm assuming I want fbclient_ms.lib, I can get rid of this with this command:

    qmake INCLUDEPATH+="C:\Firebird\Firebird_2_5\include" "LIBS+=-LC:\Firebird\Firebird_2_5\lib -lfbclient_ms" ibase.pro

    but then I'm on a LINK error...

    LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt

    Disabling incremental linking didn't work (if I did it right) checking my service pack 1 is installed.



  • Hurah! Service pack 1 did the trick. Database library compiled, working. I got a few runtime errors but that was because I was trying to debug with the release qt libraries linked.

    Now it runs! Runs! At last!

    Thanks for all the help.


  • Lifetime Qt Champion

    You're welcome !

    Since you have it working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)

    Also, while browsing the forum, consider up-voting answers that helped you, it will make them easier to find for other users :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.