Error accessing GStreamer Library - Program excited with code 0xc0000135 when Debugging



  • I want to use gstreamer library for video programming and I read that Qt5.5.0 provided support for gstreamer-1.0, which is the library I use. I downloaded firstly version 1.0.7, but I got the following error, so I downloaded the latest version 1.5.2, which I am trying to use now.

    I managed to link the gstreamer library header files, so I didn't build it, but just include its path and access the header files and libs. Anyway, now I have an error of The program has unexpectedly finished. When I try to debug it, I get the following error in a pop-up:
    During startup program excited with code 0xc0000135.

    On General Messages:
    <dump of C:\Qt\Qt5.5.0_Android\5.5\mingw492_32\qml>:1:24: Reading only version 1.1 parts.
    <dump of C:\Qt\Qt5.5.0_Android\5.5\mingw492_32\qml>:10:5: Expected only Component and ModuleApi object definitions.

    I read many questions related to this error, but none helped, I think is an error with the gstreamer library, but may be a compiler/debugger error too, as I read in some threads.

    I checked my PATH variable, as I also can not run the program outside Qt (by trying to run the .exe in debug folder of the build) - the error : library Qt5Cored.dll missing - and I found this paths:

    C:\Qt\Qt5.5.0_Android\5.5\mingw492_32\lib;
    C:\Users\user\Documents\build-GStreamer-test5-Desktop_Qt_5_5_0_MinGW_32bit-Debug;
    C:\Qt\Qt5.5.0_Android\5.5\mingw492_32\bin;
    C:\Qt\Qt5.5.0_Android\Tools\mingw492_32\bin;
    C:\Windows\system32; C:\Windows; C:\Windows\System32\Wbem; C:\Windows\System32\WindowsPowerShell\v1.0;
    C:\Program Files\Skype\Phone\ (I dont know why is this included, but it was there when I checked )

    I am relatively new to Qt, and never encountered this error before. If you need any code:

    .pro:

    QT += core gui

    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets

    TARGET = GStreamer-test5
    TEMPLATE = app

    SOURCES += main.cpp
    mainwindow.cpp

    HEADERS += mainwindow.h

    FORMS += mainwindow.ui

    INCLUDEPATH += C:/gstreamer/1.0/x86/include/gstreamer-1.0
    C:/gstreamer/1.0/x86/lib/gstreamer-1.0/include
    C:/gstreamer/1.0/x86/include/glib-2.0
    C:/gstreamer/1.0/x86/lib/glib-2.0/include

    LIBS += -L C:/gstreamer/1.0/x86/lib/ -lgstreamer-1.0

    and .main:

    #include "mainwindow.h"
    #include <QApplication>

    #include <QDebug>

    #include <stdio.h>
    #include "gst/gst.h"

    void *__gxx_personality_v0;

    int main(int argc, char *argv[])
    {
    QApplication a(argc, argv);
    MainWindow w;
    w.show();

    const gchar *nano_str;
    guint major, minor, micro, nano;

    gst_init (&argc, &argv);

    gst_version (&major, &minor, &micro, &nano);

    if (nano == 1)
    nano_str = "(CVS)";
    else if (nano == 2)
    nano_str = "(Prerelease)";
    else
    nano_str = "";

    // printf ("This program is linked against GStreamer %d.%d.%d %s\n", major, minor, micro, nano_str);

    qDebug() << "This program is linked against GStreamer %d.%d.%d %s\n", major, minor, micro, nano_str ;

    return a.exec();

    Firstly, I had the error :
    undefined reference to `__gxx_personality_v0' , but fixed it by adding *void __gxx_personality_v0; , although I don't know what excatly it is.

    Its been three days I struggle with this problem. Any help appreciated, or maybe if you can help me by some code on how to access the header files and libs, or how the configuration of the debugger options / PATH must be.

    I am using Qt5.5.0 for Android, for Windows I use MinGW 4.9.2 32 bit compiler and GNU gdb 7.8 as debugger.

    Thanks in advance!



  • I managed to solve the above problem. I had to include in the .exe folder (the build-debug folder) all the dlls included, so I tried to run the .exe from there, not run it from Qt, and some errors with dlls missing gave me the names of the dlls. I found some in my library bin folder and some downloaded, and now everything seems fine :)


  • Lifetime Qt Champion

    Hi,

    You are probably missing the path to your GStreamer dlls in your PATH (the one in Qt Creator not for your system)

    You can modify it in the Run part of the Projects Panel



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.