porting existing QtWidget app from linux to android



  • Hi Qt gurus,

    I have Qt 5.5.0 installed on my linux mint 17 OS. I have also installed Android SDK, NDK tools and all other requirements needed to build apps for android devices. I followed the instructions given in http://doc.qt.io/qt-5/android-support.html and I was able to build and run an example app on my android device.

    I am now trying to port an existing Qt Widget app to my android device. The app is suppose to read some raw data from an external device connected to the android microusb and show a value in a textbox. When I compiled it for "Desktop Qt 5.5.0 GCC 64 bit" kit, everything was fine and dandy.
    But when I tried to compile it for "Android for armeabi (GCC 4.9 Qt 5.5.0) it throws the following error:

    In file included from ../Qtdemo_full_demo/application.cpp:1:0:
    ../Qtdemo_full_demo/application.h:5:27: fatal error: libavs/as5216.h: No such file or directory
    #include "libavs/as5216.h"
    ^
    compilation terminated.

    libavs.so is an OEM library which gives me access to a spectrophotometer device.

    I have tried to add the library using the Projects->Build Android APK->Additional Libraries.
    And I can see from my .pro file that it has been added, but the compiler still doesn't recognize the library.

    My questions are:

    1. How do I solve the error above. Is there a setting I have to tweak?
    2. Are there any step by step guides (with examples) to port existing Qtwidget program to an android device? I know that there is a "porting to android" support page and I have read it. But the guide is too general for nubes like me to understand.

    Please oh please help me. Thanks


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.