Qt World Summit: Submit your Presentation

QML WebView display problems on IMX6

  • Hi,

    I'm currently facing a problem with my embedded application, and I hope you guys can help me.

    I run a QML application on an IMX6 board using buildroot. There were no problems, until I try to display a web page. Since I havn't the QtWebEngine installed, I'm using a WebView component, but when the page is displayed, the displayed page is bugged (see this photo).

    I have found a way to display coretly the web page, by changing the bootloader args with bpp=32. But when I do that, the default resolution of my framebuffer is going from 800x480 to 1024x768 (sys/class/graphics/fb2/mode : D:1024x768p-60).
    When my resolution is wrong, the QML app is displayed without problem on my screen, but the touchscreen is calibrated for the wrong resolution, and the app is unusable, BUT the WebView is now working, and the web page is perfectly displayed.

    There is my bootloader command line :

    setenv bootargs_base setenv bootargs console=ttymxc3,115200 vmalloc=400M consoleblank=0 video=mxcfb0:dev=ldb,sin0,LDB-WVGA,if=RGB666,bpp=32 fbmem=28M,10M

    I have also tried to keep the 800x480 resolution, and write 32 in /sys/class/graphics/fb2/bits_per_pixel, but the bug is still present.

    I'm wondering, since I am using fb2, is video=mxcfb0:dev=ldb the right argument ?
    Does the WebView need a color depth of 32 ?
    Why does the WebView works only when the resolution is the wrong one ?
    Have you any idea what am I doing wrong ?

    I've suceffuly set the 800x480 resolution with bpp 32 by switching mxcfb0 with mxcfb1 (mxcfb0 -> fb0 fb1 / mxcfb1 fb2 fb3 since every fb have a duplicate, correct me if I'm wrong but I've read that)
    The WebView is still bugged. Does WebView (QtWebKit 3.0) support 800x480 ?

    Thanks !