[Solved] Pi2 QT5.4.1 - STD errors + Configure errors?



  • I have been following this tutorial on how to compile QT5.4.1 on a Raspberry Pi 2. I have done this in the past for 5.3.2 and all has gone well before. The project I am working on now requires 5.4.1 minimally, so it was time to do the long compile again.

    Upon getting everything set up using an Ubuntu 14.04 (Trusty) image, I noticed some issues from the tutorial, despite it being only a few months old. For starters, I had to change libxcb-sync0 to libxcb-sync1, along with libxcb-sync0-dev to libxcb-sync-dev. No big deal, I had to do that with 5.3.2 before.

    Upon running configure, this is where things started to go wrong. I have a pastebin of the output, but it seemed to have issues getting qmake properly set up. I wasn't sure if this was just how it determined what was available or not so I just left it be, but I didn't remember seeing such a mess when dealing with 5.3.2's configure.

    Upon running make, this is where things went south with an error that was supposedly fixed. The error is as follows:

    usr/include/c++/4.8/bits/stl_relops.:67: Parse error at "std"
    make[3]: *** [.moc/moc_qabstractanimation.cpp] Error 1
    

    From what I looked up, it was just an error in one of the releases for 5.4.1, but I could be wrong. Between the qmake build issues and the odd std issue, I'm at a loss on what is really going on, and would rather consult the forums before I go poking around the code to attempt to fix it myself. Unfortunately, I ran the make command twice, so my prior log got overwritten.

    My only criteria is that I am using at least 5.4.1 or newer, so if this kind of issue was resolved in a later build or version, and it has been known to compile on the Pi2 without too many issues, I am all for it. I do need QtWebkit and other multimedia extensions, but those I can work out after I have at least the base working. If someone could help me out in working out the issues here, that would be greatly appreciated.



  • Solved. Just started compiling 5.4.2 and just small issues that are easier to resolve.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.