Qt World Summit: Submit your Presentation

General broblem with QBS??? (SOLVED)

  • Hello every one!
    I have a problem with Qbs plagin at last released Qt-5.5.

    My OS is Ubuntu x64, default GCC - 5.x. I'v just installed Qt and activated some plugins like Qbs, Bare Metal and have deactivated some of Control version plugins and Qnx.

    Also I'v added an own kit that consists an arm-none-eabi compiler and debugger.
    Then when I'm trying open a Qbs project, I get this one issue:

    ../Qt/Tools/QtCreator/share/qtcreator/qbs/share/qbs/modules/cpp/genericunix-gcc.qbs:34: error: TypeError: Result of expression 'qbs.toolchain' [undefined] is not an object.

    So, can anybody talk to me what I should do to fix this one?

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What kind of project is it ? Which Kit are you using when it happens ?

  • Hi, this is a project for embedded SW for discovery-board.
    I'm using GNU ARM Toolchain. So, compiler is an arm-none-eabi-gcc and debugger is an arm-none-eabi-gdb.

    Also, I'm going to to install previous version of Qt, I hope it will work..

  • I'v found that Qbs "Hello World" in latest Qt works well with default Qt-kits, but doesn't want to work with GNU Arm Toolchain..(

  • Lifetime Qt Champion

    Does your kit work with a qmake project ?

  • Okay, maybe its my fault. I'v solved this one simply:

    • first time I used a Qt for x64 system architect, 'cause my OS is x64 and I had previously described trouble;
    • at last time I installed Qt for x86 system and set new kit config for my project, previous kit was saved, but didn't work again. Fortunately new kit configs work well.

    The main cause of my trouble is using GNU ARM Toolchain for x86 system (I think so, but I'm not sure completely that I use x86 toolchain) - this one is the default build that simple user can install from official ppa-sources