Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] QTIFW installer crashes on Mac OSX



  • Mac OS (10.10.3) Yoxemite for dev and testing
    Qt 5.4.2 / QTIFW 2.0.1 (latest downloads for both)

    Building an offline installer, which is based off the examples/tutorial.

    Initially installer would not build complained of not finding lib installer.1.dylib
    got that fixed, but the deployed installer crashes on my test Mac and complains for the same lib:
    Dyld Error Message:
    Library not loaded: libinstaller.1.dylib
    Referenced from: /Users/USER/Desktop/Installer.app/Contents/MacOS/Installer
    Reason: image not found

    After the installer built I really expected it to just work since there has been minimal customization done so far.

    Thanks in advance!

    While getting the installer to build I employed:

    • otool to look at which libs were needed
    • install_name_tool -change to update versions of libs used
    • and made symbolic links to libs that were in a dir that was not expected...

    Could this be another bug on Mac for the QTIFW?


  • Lifetime Qt Champion

    Hi,

    What about using macdeployqt on your Installer.app, it should copy frameworks/libs/fix links for you.



  • @SGaist seems "recursively" odd, but I'll try it
    @SGaist u the man, that fixed it! TYVM
    I had intuitively expected that making an installer would result in a binary that was ready for deployment...


  • Lifetime Qt Champion

    I agree with you. However, I haven't yet tested QtIF enough to determine if this could be considered a bug...