Debugging on N97 Device



  • Hi,

    I'm new on Symbian and Qt.
    I'm using Qt creator and I'm trying to run my application on device in debug mode.

    !http://web1.twitpic.com/img/147098730-c60b6580781d0493f941b1bbf07fb8ef.4c6a79c0-scaled.jpg(My Configuration)!

    When i launch the application (in debug mode) the IDE blocks on following step:

    Executable file: 7551 2010-08-17T11:07:52 C:\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\MyApp.exe
    Package: 8136 2010-08-17T12:43:20 C:\MY PATH\NokiaQtTests\DeviceTests\MyApp\MyApp.sis
    Deploying application to 'Nokia N97 USB (COM3)'...
    Copying installation file...

    Can someone help me?

    Thanks,
    Pedro



  • have you installed s60_5_0_app_trk_3_2_6.sisx on your device


  • Moderators

    Do you have TRK installed and running on your device? Is TRK using the right port to connect to your computer (USB/bluetooth)?

    Does your application work in non-debug mode on the device?



  • Hi,

    Thanks for the replies.

    I have the TRK installed on my device and i run it before start the application.
    If I compile the application in release mode and install it on device manually the application starts ok.

    I think the IDE can't install the application on Device. But I not understand where is the problem.

    The Device is using the COM port 3 on Windows and the TRK App shows the port 1 when is running.

    Thanks,
    Pedro


  • Moderators

    Can you please doublecheck that TRK is using USB to conenct to your PC? If I remember correctly it defaults to Bluetooth.

    Can you please go to Project Mode (Ctrl-5), there to the Symbian target, Run settings. Below the "Device and serial port" combobox there is a small button labeled with an i in a blue circle. Can you please click there. You should then get some additional information on your device. Make sure to start TRK on the device before clicking that button.

    If some information is displayed, then the connection to your device works and deployment should succeed. If not then there is a connectivity problem.

    You might try to reinstall the drivers of your phone then. If that does not help deinstalling the drivers and running a registry cleaner before reinstalling them may help. I had to do this on my computer once.



  • Hi Tobias,

    Thanks for your reply.

    Yes, on my device I changed the TRK to use the USB connection (By default it use the Bluetooth).

    In the Project Mode view, my QtCreator version don't have the "Run settings". In this "page":http://wiki.forum.nokia.com/index.php/Qt_Creator_and_on_device_debugging_with_AppTRK I see that exists the Run settings but my IDE don't have it.

    Can I be doing something wrong to these settings did not show up on my IDE?

    Thanks
    Pedro


  • Moderators

    The screenshots you refer to are using Qt Creator 1.3.x. The UI was changed in 2.0. The run settings are now located inside the targets selector ("Desktop", "Simulator, etc.) and called "Run" there.



  • Hi Tobias,

    Thanks for your reply. You are right. Sorry for the question but this environment is new for me.

    I clicked on connectivity button and appears the label "Connecting...". After while disappears and nothings is shown.

    I will try your solution.

    Thanks
    Pedro


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.