Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Question of qt installed



  • There is one question when i install qt as follow ,errors shows [../../lib/libQtNetwork.so.4.8.5] erro 1
    [sub-network-amke_default-ordered] error 2

    1.download qt-everywhere-opensource-src-4.8.5.tar.gz
    2. tar -xvfz qt-everywhere-opensource-src-4.8.5.tar.gz
    3./configure
    -prefix /usr/local/Trolltech/QtEmbedded-4.8.5-arm \ 
    -opensource
    -confirm-license
    -release -shared
    -embedded arm
    -xplatform qws/linux-arm-g++
    -depths 16,18,24
    -fast
    -optimized-qmake
    -pch
    -qt-sql-sqlite
    -qt-libjpeg
    -qt-zlib
    -qt-libpng
    -qt-freetype
    -little-endian -host-little-endian
    -no-qt3support
    -no-libtiff -no-libmng
    -no-opengl
    -no-mmx -no-sse -no-sse2
    -no-3dnow
    -no-openssl
    -no-webkit
    -no-qvfb
    -no-phonon
    -no-nis
    -no-opengl
    -no-cups
    -no-glib
    -no-xcursor -no-xfixes -no-xrandr -no-xrender
    -no-separate-debug-info
    -nomake examples -nomake tools -nomake docs \



  • Sorry, the error is Produced when i make after ./configure .


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You need to provide more information, where did the error occur ? What is the exact message ?



  • @shangeyao said:
    hi SGaist,

    1.download qt-everywhere-opensource-src-4.8.5.tar.gz

    2.tar -xvfz qt-everywhere-opensource-src-4.8.5.tar.gz
    3./configure
    -prefix /usr/local/Trolltech/QtEmbedded-4.8.5-arm
    -opensource
    -confirm-license
    -release -shared
    -embedded arm
    -xplatform qws/linux-arm-g++
    -depths 16,18,24
    -fast
    -optimized-qmake
    -pch
    -qt-sql-sqlite
    -qt-libjpeg
    -qt-zlib
    -qt-libpng
    -qt-freetype
    -little-endian -host-little-endian
    -no-qt3support
    -no-libtiff -no-libmng
    -no-opengl
    -no-mmx -no-sse -no-sse2
    -no-3dnow
    -no-openssl
    -no-webkit
    -no-qvfb
    -no-phonon
    -no-nis
    -no-opengl
    -no-cups
    -no-glib
    -no-xcursor -no-xfixes -no-xrandr -no-xrender
    -no-separate-debug-info
    -nomake examples -nomake tools -nomake docs \

    1. make ,
      errors shows
      [../../lib/libQtNetwork.so.4.8.5] erro 1
      [sub-network-amke_default-ordered] error 2

  • Lifetime Qt Champion

    The real error is printed upper in the log, it's that one that gives all the details.


Log in to reply