[SOLVED] QSystemTrayIcon icon from resource file isn't showing



  • Hi.
    I'm very new to Qt so sorry if I missed something and this is a trivial problem.

    I want to have an app that has no window, it will run in the background and will have a tray icon for user interaction.
    I managed to do that using this code:

    int main(int argc, char* argv[]) {
        QApplication app(argc, argv);
    
        QAction* quitAction = new QAction(QObject::tr("&Quit"), &app);
        app.connect(quitAction, SIGNAL(triggered()), qApp, SLOT(quit()));
    
        QMenu* trayIconMenu = new QMenu();
        trayIconMenu->addAction(quitAction);
    
        QSystemTrayIcon* trayIcon = new QSystemTrayIcon();
        trayIcon->setContextMenu(trayIconMenu);
        trayIcon->setIcon(QIcon(":/appicon"));
        trayIcon->show();
    
        return app.exec();
    }
    

    This works well, as the app seems to be running and I can close it using the context menu of the tray icon.
    There's one problem though and that is that the icon itself isn't showing, the tray icon is an invisible square.

    My resource file looks like this:

    <!DOCTYPE RCC>
    <RCC version="1.0">
        <qresource>
            <file alias="appicon">images/appicon.png</file>
        </qresource>
    </RCC>
    

    In the Resource Editor of the Qt Creator I see the icon and it's the right one, but I can't seem to make the app use it when it runs.

    What am I doing wrong here?

    Thanks


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Which version of Qt are you using ? On what OS ?



  • I'm using the latest Qt (5.4.2) on a windows 8.1 machine.

    Thanks


  • Moderators

    Try setting an icon on your quit action to see if the resource is being loaded properly, i.e.

    QAction *quitAction = new QAction(QIcon(":/appicon"), "&Quit", &app);
    

    Now when you click into your menu on the systray the Quit option should have your icon next to it. If it doesn't you have an issue loading your resource.



  • I tried your suggestion and there's no icon in the menu item as well (only a blank transparent square).
    What might be the problem with loading the resource?

    The resource file code is in the original post, here's the part in the .pro file that is relevant:

    RESOURCES += qml.qrc \
        images.qrc
    

    And as I wrote before when I look at the images.qrc in the resource editor I can clearly see the image, it has no problem loading it then.

    Thanks.



  • I've the same issue with Qt 5.5.0. I do not got it on Qt 5.4.2 so this may be a new bug in Qt 5.5 ?



  • I've just fixed the bug by removing the alias !



  • I tried removing the alias now as well but it did not fix things, the same thing.
    Maybe I don't use the correct path without the alias, is this correct (using the same example as before):

    trayIcon->setIcon(QIcon(":/images/appicon.png"));
    

    Also, maybe it has something to do with the image size?
    Can I use images of any size and ratio? or am I limited in that?

    Thanks.



  • Huum if you're using QtCreator, open the file tree, open the tree of your resource file then do a right click on your image file. Click on copy full path (or something like that) then paste the path in your code :)



  • I tried that yesterday but it did not help, and looked weird as this is what I get:

    ://images/appicon.png
    

    which has two slashes while I usually see only one used.

    in any case, I tried it now again and to no avail, I get the same result.



  • No, theorically qt creator propose to you a second option wich start with

    qrc:/

    You've it or not ?



  • Nope.

    All I have when I right click on the image in the resource editor is "Copy Resource Path to Clipboard" and the result is what I posted.



  • No, not in the resource editor, in the file tree on the left !



  • Oh. sorry about that.

    I tried that now as well, and the same thing happens (or doesn't happen).


  • Moderators

    It tries to scale images, but it you were using a really crazy size it may exhibit behavior like that. What happens if you do this:

    QLabel *label = new QLabel();
    label->setPixmap(QPixmap(":/images/appicon.png");
    label->show();
    

    If it shows there then you may have an issue with it being converted to a QIcon in which case I would check your sizing of the image. I.e. try to get it no more than like 32x32 for that area since it is going to scale down to 16x16 more than likely.



  • Well, doing that was a bit over my Qt skills (controlling qml from c++), but I tried using a different image.
    I created a 16x16 one color png, added that to the resource file and tried using that, but once again to no avail.
    So it's probably not the image I was trying to use, but a problem with the resources or how I try to fetch them.

    Any ideas?
    Thanks.


  • Moderators

    @nitzan I just noticed in your resource file you don't have a prefix. Maybe try the following qrc file:

    <!DOCTYPE RCC>
    <RCC version="1.0">
        <qresource prefix="/">
            <file>images/appicon.png</file>
        </qresource>
    </RCC>
    

    Notice that prefix="/" on <qresource>.

    I also removed the alias so there isn't any issue there. Then in your load code do:

    trayIcon->setIcon(QIcon(":/images/appicon.png"));
    

    I think that might work. If not let me know any I'll write up a quick example that does work and send you the code and you can compare it to yours and figure out what is missing. :)



  • I added the prefix and it had no effect.
    Here's my current code.

    Resource file:

    <!DOCTYPE RCC>
    <RCC version="1.0">
        <qresource prefix="/">
            <file>images/appicon.png</file>
            <file>images/simpleIcon.png</file>
        </qresource>
    </RCC>
    

    cpp file:

    QAction* quitAction = new QAction(QIcon(":/images/appicon.png"), QObject::tr("&Quit"), &app);
    app.connect(quitAction, SIGNAL(triggered()), qApp, SLOT(quit()));
    
    QMenu* trayIconMenu = new QMenu();
    trayIconMenu->addAction(quitAction);
    
    QSystemTrayIcon* trayIcon = new QSystemTrayIcon();
    trayIcon->setContextMenu(trayIconMenu);
    trayIcon->setIcon(QIcon("qrc:/images/simpleIcon.png"));
    trayIcon->show();
    

    The appicon is the original icon, with an image which is 83x83, and the simpleIcon is just a 16x16 solid color image.
    Both aren't showing.
    Thanks.


  • Moderators

    @nitzan Sorry, got a ton going on at work right now. I will be able to mess around with your code a bit tomorrow probably and I'll let you know what I find out.



  • Something weird happened.
    I haven't changed anything but now I do see an icon in the QAction, but not in the tray, even if I use the same exact object, like so:

    QIcon icon(":/images/appicon.png");
    QAction* quitAction = new QAction(&icon, QObject::tr("&Quit"), &app);
    ...
    QSystemTrayIcon* trayIcon = new QSystemTrayIcon();
    trayIcon->setIcon(&icon);
    ...
    

    No idea what causes the icon to show up all of the sudden in the QAction, but fine, whatever..
    The question is why will the icon show up there but not in the tray?

    Thanks.


  • Moderators

    That sounds like a build issue. Try making sure your build environment is totally clean and rebuild. Check out a fresh copy from source control even. Or at a bare minimum make distclean then make.

    See if that resolves your icon issues.

    I'll still play with your code in a bit, just haven't had time yet.



  • You're right, it's a build issue.

    Rebuilding it produced many errors it did not complain about before, meaning that all of the last time I clicked the run button did not really compile my changed code and I kept checking the same thing.

    Now it's stuck on

    qtmaind.lib(qtmain_win.obj):-1: error: LNK2019: unresolved external symbol _main referenced in function _WinMain@16
    

    No matter what I do, I tried running qmake, cleaning all and rebuilding all but nothing seems to make it want to recompile my changed code.
    There's nothing to check out, it's a completely new project with the minimum of code I posted.


  • Moderators

    Ok then this is probably not an icon issue with systray. In fact one of the suggestions above probably fixed it but we never knew because of the build issues.

    So moving on to the build issues:

    1. Can you show me your *.pro file?
    2. What OS are you using?
    3. What IDE are you using since you said "clicked run" before I'm assuming you aren't using the command line. :)
    4. What compiler are you using?


  • Yes, you are correct again.
    I created a new project and copied just the icon related code and the icon does appear now in the tray.

    As for the build issue:
    I'm developing on windows 8.1, using the Qt Creator (as I can't seem to find an addin to visual studio 2013 (I found this: http://download.qt.io/official_releases/vsaddin/qt-vs-addin-1.2.4-opensource.exe.mirrorlist but it won't run on my machine).
    But it uses the VS2013 compiler.

    Here's my .pro file:

    TEMPLATE = app
    
    QT += qml quick widgets
    
    HEADERS += source/*.h
    SOURCES += source/*.cpp
    
    RESOURCES += qml.qrc \
    	images.qrc
    
    # Additional import path used to resolve QML modules in Qt Creator's code model
    QML_IMPORT_PATH =
    
    # Default rules for deployment.
    include(deployment.pri)
    
    DISTFILES += \
    	images/appicon.png
    
    #win32:CONFIG(release, debug|release): LIBS += -L$$PWD/../../CEF/cef_binary_3.2357.1280.geba024d_windows32/release/ -llibcef
    #else:win32:CONFIG(debug, debug|release): LIBS += -L$$PWD/../../CEF/cef_binary_3.2357.1280.geba024d_windows32/debug/ -llibcef
    
    #INCLUDEPATH += $$PWD/../../CEF/cef_binary_3.2357.1280.geba024d_windows32
    #DEPENDPATH += $$PWD/../../CEF/cef_binary_3.2357.1280.geba024d_windows32
    
    #win32-g++:CONFIG(release, debug|release): PRE_TARGETDEPS += $$PWD/../../CEF/cef_binary_3.2357.1280.geba024d_windows32/release/liblibcef.a
    #else:win32-g++:CONFIG(debug, debug|release): PRE_TARGETDEPS += $$PWD/../../CEF/cef_binary_3.2357.1280.geba024d_windows32/debug/liblibcef.a
    #else:win32:!win32-g++:CONFIG(release, debug|release): PRE_TARGETDEPS += $$PWD/../../CEF/cef_binary_3.2357.1280.geba024d_windows32/release/libcef.lib
    #else:win32:!win32-g++:CONFIG(debug, debug|release): PRE_TARGETDEPS += $$PWD/../../CEF/cef_binary_3.2357.1280.geba024d_windows32/debug/libcef.lib
    

    As can be seen, I added a library (chromium embedded framework) but after reading about how that error is caused when adding additional libs I commented it out, but still that error would not go away.
    It's probably something to do with the Qt Creator which caches things?



  • Ok, I finally managed to get everything working!

    What I did was to set the Default build directory to . instead of what it has there, and I unchecked the Use jom instead of nmake box.
    Now it seems to actually rebuilding the up to date code.

    Thanks for all the help!


  • Moderators

    Good, glad ya got it sorted out. Sorry I've been super busy lately and haven't lurked the forums here. :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.