[SOLVED] Qt creator should not change the file in view after refactoring etc.

  • Hello!

    Usually I have split my Qt-Creator-Windows side by side.

    Now let's say file.h is on the left side, file.cpp is on the right side.

    If I right-click a function in file.h and tell Qt to "Add definition in file.cpp", it will show me said definition in file.cpp on the left side.

    Explanatory Image on Imgur.com

    Whilst I am already looking at file.cpp on the right side, that is totally unnecessary. Is there a way to turn off that behaviour?
    I want my cursor to never jump away from it's current position without being asked.
    Not when I am refactoring, not when I click the little light-bulb, etc.

    It would be nice, if there was a check-box to uncheck for that I haven't found yet.

    Kind regards,


  • Lifetime Qt Champion


    You should check the bug report system to see if there's already something like that that has been asked. If not you could make a feature request. If you would like to talk about it first, the the Qt Creator mailing list seems to be a good place to start.

  • Hi SGaist,

    after browsing the bug reports for a while, I have found my issue in QTCREATORBUG-13145.
    (Maybe there are more. I have stopped looking after I found this one.)

    So far nothing happened.
    Maybe I will create an account there and bump the issue with a comment.

    Thanks for the tip and I will mark this [SOLVED] because: "Can't be done, yet."

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.