Compile-Build KDSoap libraries

  • Hi, my problem is build in 32 bits version, the library KDSoap but my system is 64 bits, (i do builded easily version of 64 bits).
    In documentation says execute a python script and later execute a MAKE file(in the python options only use static and release), exist a file of g++.pri (here i modify the lines adding -m32 in CFLAGS),

    Here is mi g++.pri

    *-g++* {
       NORMAL_CFLAGS = -Wno-long-long -ansi -m32 
       win32-g++ {
     -Wnon-virtual-dtor -Wundef -Wcast-align \
     -Wchar-subscripts -Wpointer-arith \
     -Wwrite-strings -Wpacked -Wformat-security \
     -Wmissing-format-attribute -Woverloaded-virtual
    # -Wconversion gives too many warnings from Qt-4.4.3 with gcc-4.3.2 (was fine with gcc-4.2.4), so removing it
    NORMAL_CFLAGS += -pedantic -m32
    CONFIG(debug, debug|release) {
    NORMAL_CXXFLAGS += -O0 -g3 -m32 
    USABLE_CXXFLAGS = -Wold-style-cast -m32 
    HARD_CXXFLAGS = -Weffc++ -Wshadow -m32 
    PITA_CXXFLAGS = -Wunreachable-code -m32 
    #QMAKE_CXXFLAGS_WARN_ON += $$HARD_CXXFLAGS # headers must compile with this, code doesn't need to; needs patched Qt
    #QMAKE_CXXFLAGS_WARN_ON += $$PITA_CXXFLAGS # header would be nice, but it's probably pointless, due to noise from Qt and libstdc++

    I probed using a Qt version of 32 bits, but i get a lot errors( like says "libQt5... is incompatible"), when i use a qt version of 64 bits, i only get errors like that:
    "/usr/bin/ld: se salta el /home/artur/proyects/KDSoap/lib/libxmlcommon.a incompatible find -lxmlcommon" (this error is repeated for every will generate file .so)

  • Lifetime Qt Champion


    If you want to build KDSOAP for 32bit then just use a 32bit Qt build. You'll avoid all these troubles

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.